Bug 5942 - network kickstart fails for non-autodetect ethernet
network kickstart fails for non-autodetect ethernet
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-14 06:18 EDT by jalar
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 09:29:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jalar 1999-10-14 06:18:39 EDT
I have ISA NE2000 which is not autodetected.

In 6.0, when a (network) kickstart install failed to find
an ethernet card, you were asked to provide the card and
was able to give io and irq, and then the kickstart
install continued.

In 6.1 you are simply kicked (!) out of the kickstart
install.
Comment 1 Jay Turner 1999-10-21 14:22:59 EDT
This issue has been forwarded to a developer for further action.
We have seen where problems encountered in kickstart cause the whole
thing to crash down.
Comment 2 Erik Troan 1999-12-21 10:26:59 EST
The behavior of network kickstarts is undefined when the ethernet card cannot
be found. The kickstart "device" keyword is provided to let your kickstart
install probe for additional (ISA) cards.
Comment 3 jalar 1999-12-23 05:40:59 EST
Sadly, this renders the kickstart magic unusable for me.
There remains two problems:

a) I have a collection of machines with different configurations,
and therefore for me it is a big bonus to be able to have the
kickstart file(s) centrally (on a NFS server). But I can't put
the device info in that file, because _how_ is a client being
installed going to access this info if the ethernet card is not
available?

b) Even if I resort to having a number of different floppies for
the different machines, the "device" keyword does not work
correctly. I use 'device ethernet ne --opts "io=0x280, irq=9"'.
It does check for an ne ethernet device, but only at 0x300. It
doesn't find the card at 0x280.

I would therefore suggest:

1) Define the "undefined" behaviour to be: 'if the network
detection fails, ask the (poor) user what ethercard to use, and
then return to the kickstart install.' This was the behaviour in
6.0, so I am a bit surprised that it changed into something less
usable in 6.1 (!).

2) Check the bug in the "device" keyword

By the way, you could possibly rewrite the kickstart section in
the reference manual so that it really talks about 6.1 (it is
currently a direct copy of the 6.0 section, and thus is incorrect
in a few places)
Comment 4 Jay Turner 2000-02-11 09:22:59 EST
The device thing in kickstart is fixed in the latest installer (available in
beta).  I have added the other issue to a list of features for future releases.

Note You need to log in before you can comment on or make changes to this bug.