Bug 594206 - wrong users and groups creation in spec file
Summary: wrong users and groups creation in spec file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: yanfu,wang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 593683
TreeView+ depends on / blocked
 
Reported: 2010-05-20 14:41 UTC by Peter Vrabec
Modified: 2010-11-10 21:14 UTC (History)
3 users (show)

Fixed In Version: nfs-utils-1.2.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:14:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Vrabec 2010-05-20 14:41:49 UTC
Description of problem:
Please fix user/group creation in your spec file[1]. There were problems when
(UID != GID) && (UID<200) [2]. For example:
tryitd:x:194:482:TryIt:/:/sbin/nologin

Problem was caused by change/fix of shadow-utis behaviour. useradd does not
create group with same GID as user's UID for IDs < 200 (static/reserved) unless
it's done this way:

getent group qemu >/dev/null || groupadd -g 107 -r qemu
getent passwd qemu >/dev/null || \
  useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
    -c "qemu user" qemu


This issue should be fixed as soon as possible. Note, it can't be resolved by
any update once we have RHEL6 GA. Please fix it in Fedora too. thnx.

--------
[1] https://fedoraproject.org/wiki/Packaging:UsersAndGroups 
[2] https://bugzilla.redhat.com/show_bug.cgi?id=593683

Comment 1 Steve Dickson 2010-05-25 19:59:24 UTC
Why is this an nfs-utils issue?

Comment 3 Peter Vrabec 2010-07-21 09:45:30 UTC
I see that rpcuser with UID 29 is created in nfs-utils.spec

/usr/sbin/useradd -l -c "RPC Service User" -r \
        -s /sbin/nologin -u 29 -d /var/lib/nfs rpcuser 2>/dev/null || :

according to /usr/share/doc/setup-*/uidgid, there should be also group with same GID created as well. Unfortunately the group is not being created according the packaging guidance.

The goal is to create rpcuser(user/group) in same way as nfsnobody.

Comment 5 yanfu,wang 2010-08-03 05:55:37 UTC
verified on i386 and x86_64 without problem:
# uname -a
Linux dell-pem605-01.rhts.eng.bos.redhat.com 2.6.32-54.el6.x86_64 #1 SMP Wed Jul 28 00:06:54 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-pem605-01 ~]# rpm -qa|grep nfs-utils
nfs-utils-1.2.2-5.el6.x86_64
nfs-utils-lib-1.1.5-1.el6.x86_64
# id rpcuser
uid=29(rpcuser) gid=29(rpcuser) groups=29(rpcuser)

Comment 6 releng-rhel@redhat.com 2010-11-10 21:14:19 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.