Bug 594405 - wrong users and groups creation in spec file
Summary: wrong users and groups creation in spec file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: avahi
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Lennart Poettering
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 593683
TreeView+ depends on / blocked
 
Reported: 2010-05-20 15:04 UTC by Peter Vrabec
Modified: 2010-11-10 19:56 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-11-10 19:56:08 UTC


Attachments (Terms of Use)

Description Peter Vrabec 2010-05-20 15:04:45 UTC
Description of problem:
Please fix user/group creation in your spec file[1]. There were problems when
(UID != GID) && (UID<200) [2]. For example:
tryitd:x:194:482:TryIt:/:/sbin/nologin

Problem was caused by change/fix of shadow-utis behaviour. useradd does not
create group with same GID as user's UID for IDs < 200 (static/reserved) unless
it's done this way:

getent group qemu >/dev/null || groupadd -g 107 -r qemu
getent passwd qemu >/dev/null || \
  useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
    -c "qemu user" qemu


This issue should be fixed as soon as possible. Note, it can't be resolved by
any update once we have RHEL6 GA. Please fix it in Fedora too. thnx.

--------
[1] https://fedoraproject.org/wiki/Packaging:UsersAndGroups 
[2] https://bugzilla.redhat.com/show_bug.cgi?id=593683

Comment 1 Matthias Clasen 2010-05-28 13:14:17 UTC
Looks like an easy fix. Can you take care of this, Lennart ?

Comment 2 Matthias Clasen 2010-06-09 15:11:08 UTC
Any update on this, Lennart ?

Comment 5 releng-rhel@redhat.com 2010-11-10 19:56:08 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.