Bug 594445 - Error in PREIN scriptlet in rpm package imsettings-0.108.0-3.1.el6.x86_64
Error in PREIN scriptlet in rpm package imsettings-0.108.0-3.1.el6.x86_64
Status: CLOSED DUPLICATE of bug 593964
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: imsettings (Show other bugs)
6.0
All Linux
high Severity high
: beta
: ---
Assigned To: Akira TAGOH
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 13:11 EDT by Jay Turner
Modified: 2015-01-07 19:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 14:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2010-05-20 13:11:14 EDT
Description of problem:
Getting the following error attempting to update from imsettings-0.107.4-4.el6 -> imsettings-0.108.0-3.1.el6:

Error in PREIN scriptlet in rpm package imsettings-0.108.0-3.1.el6.x86_64
/var/tmp/rpm-tmp.qeGhXD: line 1: fg: no job control
error: %pre(imsettings-0.108.0-3.1.el6.x86_64) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping imsettings-0.108.0-3.1.el6
imsettings-0.107.4-4.el6.x86_64 was supposed to be removed but is not!

Failed:
  imsettings.x86_64 0:0.108.0-3.1.el6                                                  

Version-Release number of selected component (if applicable):
0.108.0-3.1.el6

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to the 0.108.0-3.1.el6 packages
2.
3.
  
Actual results:


Expected results:


Additional info:
This is happening because imsettings scripts have been updated to use the new GConf2 rpm macros, but those are not available in RHEL6 and does not appear there are plans to port them.  The %pre, %post and %preun scripts need to be returned to their original states.
Comment 1 Bill Nottingham 2010-05-20 14:21:16 EDT

*** This bug has been marked as a duplicate of bug 593964 ***

Note You need to log in before you can comment on or make changes to this bug.