Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 594446 - crash mounting ext4 with invalid options
Summary: crash mounting ext4 with invalid options
Keywords:
Status: CLOSED DUPLICATE of bug 614957
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 17:13 UTC by Jack Tanner
Modified: 2010-11-09 13:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-09 16:46:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jack Tanner 2010-05-20 17:13:48 UTC
Description of problem:

ext4 doesn't support mount options uid= or user= ; that's OK. Crashing when those options are given is not OK.

Version-Release number of selected component (if applicable):

e4fsprogs-1.41.9-3.el5

hardware:

http://www.smolts.org/client/show/pub_867c9af2-f29c-4306-97c7-b28952f8c1e2

Steps to Reproduce:
1. mount -o uid=luser /mnt/foo # note error message in dmesg|tail
2. mount -o uid=luser /mnt/foo
  
Actual results:

Crash

Expected results:

Error message is repeated again.

Comment 1 Eric Sandeen 2010-05-20 20:55:33 UTC
Appears fixed upstream.  Still unhappy on 2.6.18-194.el5.

Guessing it's the same as https://bugzilla.kernel.org/show_bug.cgi?id=15230
likely fixed by my commit at http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=15121c18a22ae483279f76dc9e554334b800d0f7

.... yep confirmed.

We'll get that fixed for 5.6, thanks.

-Eric

Comment 3 Eric Sandeen 2010-06-07 14:40:55 UTC
This is actually a kernel bug, sorry I missed that it was filed for e4fsprogs.

Comment 4 Eric Sandeen 2010-08-05 20:10:28 UTC
Actually, Jack - what error messages are you getting when you do this?  You may actually be hitting bug #614957 ... in fact I think that's almost certainly it.

-Eric

Comment 5 Eric Sandeen 2010-09-01 18:15:17 UTC
Ping, Jack?  What error messages are you getting?  Lacking response I may just dup this to 614957.

-Eric

Comment 6 Eric Sandeen 2010-09-09 16:46:36 UTC

*** This bug has been marked as a duplicate of bug 614957 ***


Note You need to log in before you can comment on or make changes to this bug.