Bug 594448 - abrtd can't start at boot because of selinux
abrtd can't start at boot because of selinux
Status: CLOSED DUPLICATE of bug 593906
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 13:27 EDT by Aioanei Rares
Modified: 2015-02-01 17:52 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-21 07:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aioanei Rares 2010-05-20 13:27:28 EDT
Description of problem:

At boot or if issuing sudo /etc/init.d/abrtd start abrt has [FAILED] at its
right, no other messages.

Version-Release number of selected component (if applicable):

$ rpm -qa | grep abrt
abrt-1.1.2-1.fc14.x86_64
abrt-gui-1.1.2-1.fc14.x86_64
abrt-plugin-runapp-1.1.2-1.fc14.x86_64
abrt-plugin-bugzilla-1.1.2-1.fc14.x86_64
abrt-plugin-logger-1.1.2-1.fc14.x86_64
abrt-addon-ccpp-1.1.2-1.fc14.x86_64
abrt-libs-1.1.2-1.fc14.x86_64
abrt-addon-kerneloops-1.1.2-1.fc14.x86_64
abrt-addon-python-1.1.2-1.fc14.x86_64
abrt-desktop-1.1.2-1.fc14.x86_64


How reproducible:

everytime.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

This is what I got from /var/log/messages : 


May 20 19:03:48 localhost python: abrt: detected unhandled Python exception in /usr/bi
n/gwibber-service
May 20 19:03:48 localhost abrt[1924]: daemon is not running, python crash dump aborted
May 20 19:21:32 localhost abrtd: Can't create '/var/spool/abrt': Permission denied
May 20 19:21:32 localhost kernel: type=1400 audit(1274372492.712:26): avc:  denied  { 
write } for  pid=2109 comm="abrtd" name="spool" dev=sda2 ino=1550 scontext=unconfined_
u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir
May 20 19:21:32 localhost kernel: type=1400 audit(1274372492.713:27): avc:  denied  { 
write } for  pid=2109 comm="abrtd" name="spool" dev=sda2 ino=1550 scontext=unconfined_
u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir
May 20 19:21:51 localhost kernel: type=1400 audit(1274372511.476:28): avc:  denied  { 
write } for  pid=2115 comm="abrtd" name="spool" dev=sda2 ino=1550 scontext=system_u:sy
stem_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir
May 20 19:21:51 localhost abrtd: Can't create '/var/spool/abrt': Permission denied
May 20 19:21:51 localhost kernel: type=1400 audit(1274372511.476:29): avc:  denied  { 
write } for  pid=2115 comm="abrtd" name="spool" dev=sda2 ino=1550 scontext=system_u:sy
stem_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir
May 20 19:25:02 localhost kernel: type=1400 audit(1274372702.268:10): avc:  denied  { 
write } for  pid=937 comm="abrtd" name="spool" dev=sda2 ino=1550 scontext=system_u:sys
tem_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir
May 20 19:25:02 localhost kernel: type=1400 audit(1274372702.268:11): avc:  denied  { 
write } for  pid=937 comm="abrtd" name="spool" dev=sda2 ino=1550 scontext=system_u:sys
tem_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir
May 20 19:25:02 localhost abrtd: Can't create '/var/spool/abrt': Permission denied

There are more messages like this one pertaining to other crashes, but the denials are the same.
sudo cat /var/log/messages | grep abrt is kinda big to include here, but will do if needed.
Comment 1 Denys Vlasenko 2010-05-21 07:43:55 EDT

*** This bug has been marked as a duplicate of bug 593906 ***

Note You need to log in before you can comment on or make changes to this bug.