Bug 594479 - [QA][6.0] /etc/modprobe.conf does not exist
[QA][6.0] /etc/modprobe.conf does not exist
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Deployment_Guide (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Bara Ancincova
ecs-bugs
: Documentation
Depends On:
Blocks: 561660 994996
  Show dependency treegraph
 
Reported: 2010-05-20 15:31 EDT by Flavio Leitner
Modified: 2015-03-16 09:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-16 09:51:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2010-05-20 15:31:27 EDT
Description of problem:

/etc/modprobe.conf does not exist.
Our understanding is that the file is deprecated.  Is this correct?

On RHEL4 and 5, you can specify the order of kernel modules loading, for
example, by writing "alias host_scsiadapter xxx" in modprobe.conf. 
Is there any other means to do this on RHEL6?

Version-Release number of selected component:
Red Hat Enterprise Linux Version Number:  RHEL6

Release Number:  6.0 beta
Architecture:  x86_64
Kernel Version: 2.6.32-19.el6
Related Package Version: module-init-tools-3.9-5.el6.x86_64
Related Middleware / Application: N/A

Drivers or hardware or architecture dependency:
None.

How reproducible:
Always.

Step to Reproduce:
1. Boot RHEL6.0 beta system.
2. ls /etc/modprobe.conf

Hardware configuration:
- Model: PRIMERGY BX620S4
- CPU Info: Intel Xeon X5470
- Memory Info: 2GB
- Other:

Additional Info:
Taking a quick look at how the kernel and udev work together, 
on RHEL6.0 beta, to detect/probe devices and assign device node name 
to them, it seems to me that there is no other means to specify the 
order of kernel modules loading.

-----
Dear SEG,

On RHEL6, dracut is introduced instead of mkinitrd, then users will have 
to understand some difference with them to manage their systems. 
So, customer requests some documents about this. I think we need to 
provide the following information, at least.

 - changing package mkinitrd to dracut
   (this information has been in release notes and migration guide)
 - there isn't /etc/modprobe.conf by default
 - needing to add kernel parameter 'rdloaddriver' to order module loading instead of 'scsi_hostadapter'
 - loading all drivers to initramfs by default

As long as I checked internal/external RHEL6 beta documents, I could not
find like that. So, can we publish like the above information for 
all customers?

Best regards,
M Yamazaki
-----
Comment 2 RHEL Product and Program Management 2010-05-20 15:36:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Bill Nottingham 2010-05-20 15:55:24 EDT
/etc/modprobe.conf is still read, if the user creates it. (In RHEL 6, that is. It may go away in RHEL 7.) The user can also create a file under /etc/modprobe.d, with the same syntax. (This is more future-compatible.)

Wouldn't this be more appropriate for the Migration Guide?
Comment 4 Flavio Leitner 2010-05-20 16:39:52 EDT
Could be, the idea here is to check all RHEL 6 docs about the changes listed in the summary.
Comment 5 Michael Hideo 2010-05-20 17:09:25 EDT
Scott/Rudi,

Can you please assess this for Migration Guide/other guides?  Cheers, - Mike
Comment 6 Ruediger Landmann 2010-06-20 23:33:57 EDT
The Installation Guide doesn't ask users to do anything with modprobe.conf at all, so I think this is out of scope for that guide. 

However, I reviewed the Installation Guide for any references to mkinitrd, modprobe.conf, scsi_hostadapter, or loading drivers to initramfs. 

The only reference to any of these was a reference to mkinitrd in "25.3.4. Configuring a System z Network Device for Network Root File System", mentioned only in the context of Dracut anyway: "Dracut (the mkinitrd successor that provides the functionality in the initramfs that in turn replaces initrd) provides a boot parameter to activate network devices on System z early in the boot process"

I'm therefore changing the component to the Deployment Guide -- Dracut is discussed in section "29.5. Verifying the Initial RAM Disk Image" of that book.

However, please feel free to re-open against the Installation Guide if there's a specific place in the Installation Guide where you feel this should be mentioned.
Comment 7 Scott Radvan 2010-06-21 00:00:36 EDT
Notes have been now been added to the Migration Guide about these changes.
Comment 8 Douglas Silas 2010-06-21 16:32:23 EDT
I was aware of this change, though I just got rid of the last two lingering references to modprobe.conf (except to mention it as deprecated) in the channel bonding sections of the Network Interfaces and General Parameters chapters.

commit dd6a4c3 - GenParams, NetInterfaces: mk DG modprobe.conf-clean
	→ Fix BZ#594479: make final chgs to bonding sections to instruct in modprobe.d/ use; only mention modprobe.conf as deprecated

Othewise the Deployment Guide is modprobe.conf clean. I will CC Don so as to pass this hot potato 'round.
Comment 10 Douglas Silas 2010-06-25 09:17:32 EDT
Harald Hoyer has provided me with the rdloaddriver and module-loading specifics, so I'll be updating the General Parameters and Modules chapter with that information. Because of the nearness of the deadline, this will not make it into the beta 2 Deployment Guide release.

Note You need to log in before you can comment on or make changes to this bug.