Bug 59450 - Bad typedef in curses.h
Bad typedef in curses.h
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: ncurses (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-07 23:03 EST by Enrico Scholz
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-12 06:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-02-07 23:03:58 EST
Description of Problem:

/usr/include/ncurses/curses.h:106 contains the line

| typedef  NCURSES_BOOL;

which is an invalid C++ construct (looks like a zero-substituted @...@). It
causes problems, e.g. while compiling aspell.


Version-Release number of selected component (if applicable):

ncurses-devel-5.2-16
Comment 1 Bernhard Rosenkraenzer 2002-02-12 06:49:28 EST
You're right, it's a zero substitution, probably a missing AC_SUBST somewhere
Comment 2 Bernhard Rosenkraenzer 2002-02-12 09:47:26 EST
Fixed in 5.2-17

Note You need to log in before you can comment on or make changes to this bug.