Bug 594537 - qpid-tools package should require same package version of python-qmf
qpid-tools package should require same package version of python-qmf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
beta
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Nuno Santos
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 19:47 EDT by Pete MacKinnon
Modified: 2013-09-12 18:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-22 06:53:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete MacKinnon 2010-05-20 19:47:55 EDT
Had to manually update python-qmf to the same version of qpid-tools (0.7.946106). Seems like qpid-tools found an existing python-qmf package and was satisfied. But those package bits were incompatible.
Comment 1 Nuno Santos 2010-05-21 12:06:51 EDT
Rebuilt to include the versioned dependency: qpid-tools-0.7.946106-3

RHEL4: https://brewweb.devel.redhat.com/buildinfo?buildID=132856
RHEL5: https://brewweb.devel.redhat.com/buildinfo?buildID=132854
RHEL6: https://brewweb.devel.redhat.com/buildinfo?buildID=132858
Comment 2 Pete MacKinnon 2010-05-21 16:21:46 EDT
Seeing this as of this afternoon from the repo. Not sure it its related.

[root@mrg31 condor]# yum install python-qmf qpid-tools
Loaded plugins: rhnplugin, security
Setting up Install Process
Package python-qmf-0.7.946106-3.el5.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package qpid-tools.noarch 0:0.7.946106-3.el5 set to be updated
--> Processing Dependency: python-qmf = ${version} for package: qpid-tools
--> Finished Dependency Resolution
qpid-tools-0.7.946106-3.el5.noarch from grid-devel has depsolving problems
  --> Missing Dependency: python-qmf = ${version} is needed by package qpid-tools-0.7.946106-3.el5.noarch (grid-devel)
Error: Missing Dependency: python-qmf = ${version} is needed by package qpid-tools-0.7.946106-3.el5.noarch (grid-devel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 3 Nuno Santos 2010-05-21 16:56:12 EDT
There was a typo in the specfile, I already fixed it and rebuilt.

Note You need to log in before you can comment on or make changes to this bug.