Bug 594591 - virt-v2v: different mac address in converted guest from Xen
virt-v2v: different mac address in converted guest from Xen
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 01:53 EDT by Nan Zhang
Modified: 2010-09-06 05:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-06 05:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhel5u5-32b-pv-raw-intel.xml (1017 bytes, text/plain)
2010-07-06 02:20 EDT, Nan Zhang
no flags Details

  None (edit)
Description Nan Zhang 2010-05-21 01:53:11 EDT
Description of problem:
There is different mac address in converted guest, it will lead to guest's network interface(eth0) down.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.0-1.el5
v2v-libvirt-0.8.1-1.el5

How reproducible:
Always

Steps to Reproduce:
virt-v2v -i libvirtxml -op v2v-test /mnt/V2V_image/xen-image/intel/rhel5u5-32b-pv-raw-intel.xml
  
Actual results:
Fail to start up network interface(eth0).

Expected results:
Keeping the same mac address after conversion.

Additional info:
Comment 1 Matthew Booth 2010-06-30 09:37:22 EDT
Could you please attach the contents of /mnt/V2V_image/xen-image/intel/rhel5u5-32b-pv-raw-intel.xml?
Comment 2 Nan Zhang 2010-07-06 02:20:46 EDT
Created attachment 429679 [details]
rhel5u5-32b-pv-raw-intel.xml
Comment 3 Matthew Booth 2010-09-06 05:16:17 EDT
The MAC address in the metadata is:

00:16:36:6c:a0:a4

however the MAC address in the guest, pre-conversion is:

00:16:36:70:DB:A5

It looks like the guest and metadata don't match up. Networking would not have worked on this guest prior to conversion. There's not much we can do about that.

Note You need to log in before you can comment on or make changes to this bug.