Bug 594595 - perl-Alien-SeleniumRC bundles a precompiled jar file
perl-Alien-SeleniumRC bundles a precompiled jar file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Alien-SeleniumRC (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2010-05-21 02:20 EDT by Iain Arnell
Modified: 2010-05-28 13:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-Alien-SeleniumRC-1.01-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-23 16:36:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iain Arnell 2010-05-21 02:20:51 EDT
perl-Alien-SeleniumRC contains its own pre-built copy of selenium-server.jar which is 
- not compiled from source
- not reflected in the license tag
- forbidden by https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
- forbidden by https://fedoraproject.org/wiki/Packaging/Guidelines#No_inclusion_of_pre-built_binaries_or_libraries

Fortunately, selenium-server is already packaged and available, so it should be a trivial fix to use it rather than the bundled copy.
Comment 1 Emmanuel Seyman 2010-05-23 16:36:39 EDT
Done. Tagged and built for rawhide.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2204289
Comment 2 Toshio Ernie Kuratomi 2010-05-24 11:56:47 EDT
Note that merely building in rawhide is probably okay for bundled libraries but this particular instance was also prebuilt.  Because of that we want to push out fixes to older Fedora releases as well.

Thanks!
Comment 3 Fedora Update System 2010-05-24 21:05:40 EDT
perl-Alien-SeleniumRC-1.01-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/perl-Alien-SeleniumRC-1.01-2.fc12
Comment 4 Fedora Update System 2010-05-24 21:05:45 EDT
perl-Alien-SeleniumRC-1.01-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/perl-Alien-SeleniumRC-1.01-3.fc13
Comment 5 Fedora Update System 2010-05-24 21:05:49 EDT
perl-Alien-SeleniumRC-1.00-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/perl-Alien-SeleniumRC-1.00-3.fc11
Comment 6 Fedora Update System 2010-05-28 13:58:09 EDT
perl-Alien-SeleniumRC-1.01-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-05-28 13:59:53 EDT
perl-Alien-SeleniumRC-1.01-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.