Bug 594624 - file cannot recognize C++ header files
Summary: file cannot recognize C++ header files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Kaluža
QA Contact: Milos Malik
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 08:02 UTC by Milos Malik
Modified: 2010-11-10 20:23 UTC (History)
1 user (show)

Fixed In Version: file-5.04-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 20:23:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for regressions (1.56 KB, patch)
2010-06-11 10:56 UTC, Jan Kaluža
no flags Details | Diff

Description Milos Malik 2010-05-21 08:02:23 UTC
Description of problem:
Some C++ header files are not correctly recognized by file. I believe it's a
regression because file-5.03-12.el6 recognizes them correctly.

Version-Release number of selected component (if applicable):
file-5.04-4.el6.i686
libstdc++-devel-4.4.4-2.el6.i686

How reproducible:
always

Steps to Reproduce:
# rpm -ql libstdc++-devel | xargs file | grep HTML | tr -s ' '
/usr/include/c++/4.4.4/bits/basic_string.h: HTML document text
/usr/include/c++/4.4.4/bits/stl_map.h: HTML document text
/usr/include/c++/4.4.4/bits/stl_multimap.h: HTML document text
/usr/include/c++/4.4.4/bits/stl_multiset.h: HTML document text
/usr/include/c++/4.4.4/bits/stl_queue.h: HTML document text
/usr/include/c++/4.4.4/bits/stl_set.h: HTML document text
/usr/include/c++/4.4.4/bits/stl_stack.h: HTML document text
/usr/include/c++/4.4.4/tr1_impl/array: HTML document text
  
Actual results:


Expected results:

Comment 4 Jan Kaluža 2010-06-11 10:56:43 UTC
Created attachment 423238 [details]
Fix for regressions

Attached patch fixes regressions in file-5.0.4 which are causing described
problem. It basically removes excessive HTML/SGML "magic patterns".

Comment 7 Jan Kaluža 2010-06-11 11:44:28 UTC
Commited to CVS, fixed in version file-5.04-5.el6.

http://post-office.corp.redhat.com/archives/cvs-commits-list/2010-June/msg01612.html

Comment 9 releng-rhel@redhat.com 2010-11-10 20:23:15 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.