Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594636 - file cannot recognize C header files
file cannot recognize C header files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Kaluža
Milos Malik
: Regression
Depends On:
Blocks: 603040 610067
  Show dependency treegraph
 
Reported: 2010-05-21 04:20 EDT by Milos Malik
Modified: 2010-11-10 15:23 EST (History)
1 user (show)

See Also:
Fixed In Version: file-5.04-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 603040 (view as bug list)
Environment:
Last Closed: 2010-11-10 15:23:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for regressions (1.56 KB, patch)
2010-06-11 06:42 EDT, Jan Kaluža
no flags Details | Diff

  None (edit)
Description Milos Malik 2010-05-21 04:20:36 EDT
Description of problem:
Some .h files are not correctly recognized by file. I believe it's a regression because file-5.03-12.el6 recognizes them correctly.

Version-Release number of selected component (if applicable):
file-5.04-4.el6.i686
glib2-devel-2.22.5-2.el6.i686

How reproducible:
always

Steps to Reproduce:
# rpm -ql glib2-devel | grep '\.h$' | xargs file | grep exported
/usr/include/gio-unix-2.0/gio/gunixmounts.h:          exported SGML document text
/usr/include/glib-2.0/gio/gappinfo.h:                 exported SGML document text
/usr/include/glib-2.0/gio/gfile.h:                    exported SGML document text
/usr/include/glib-2.0/gio/gfileattribute.h:           exported SGML document text
/usr/include/glib-2.0/gio/gicon.h:                    exported SGML document text
/usr/include/glib-2.0/gio/gsocketaddressenumerator.h: exported SGML document text
/usr/include/glib-2.0/gio/gsocketconnectable.h:       exported SGML document text
/usr/include/glib-2.0/gobject/gclosure.h:             exported SGML document text
/usr/include/glib-2.0/gobject/gtypemodule.h:          exported SGML document text

  
Actual results:


Expected results:
Comment 3 Jan Kaluža 2010-06-11 06:42:37 EDT
Created attachment 423235 [details]
Fix for regressions

Attached patch fixes regressions in file-5.0.4 which are causing described problem. It basically removes excessive HTML/SGML "magic patterns".
Comment 5 Jan Kaluža 2010-06-11 07:44:24 EDT
Commited to CVS, fixed in version file-5.04-5.el6.

http://post-office.corp.redhat.com/archives/cvs-commits-list/2010-June/msg01612.html
Comment 7 releng-rhel@redhat.com 2010-11-10 15:23:17 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.