Bug 594653 - domain start failed when img is in '/home/user'
domain start failed when img is in '/home/user'
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 05:13 EDT by dyuan
Modified: 2010-06-08 09:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 09:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dyuan 2010-05-21 05:13:00 EDT
Description of problem:
confirmed a demo.img is good when it is in /var/lib/libvirt/images or /tmp or /mnt or /home etc. but when move it to /home/user, it will start with error: 

libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/1
qemu: could not open disk image /home/user/rhel6_i386.img: Permission denied

# getenforce
Permissive

Wondering is it a bug or not.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-06-07 11:59:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Daniel Berrange 2010-06-08 09:49:19 EDT
If you installed using virt-manager, it will prompt you to set appropriate permissions on $HOME. Since you moved it manually this was missed. So I'm inclined to say this is a configuration error & not a bug.

Note You need to log in before you can comment on or make changes to this bug.