Bug 594696 - Dock / Undock and sleep/wake - unable to unlock screen
Dock / Undock and sleep/wake - unable to unlock screen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: jmccann
desktop-bugs@redhat.com
:
: 577181 583661 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 07:19 EDT by Chris Ward
Modified: 2015-01-14 18:25 EST (History)
6 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.28.3-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:31:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 619773 None None None Never

  None (edit)
Description Chris Ward 2010-05-21 07:19:25 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Latest packages as of 
http://download.englab.brq.redhat.com/pub/rhel/rel-eng/RHEL6.0-20100512.0/6.0/Server/x86_64/os/


Steps to Reproduce:
example 1
1. Boot laptop undocked
2. login
3. sleep
4. dock
5. wake

example 2
1. Boot laptop docked
2. login to gnome
3. switch off laptop monitor, leaving external display ON
4. Close laptop screen
5. Set preferences so when no power and laptop screen is closed system will sleep
6. Undock system (system will sleep)
7. Dock system (while sleeping
8. Wake system (open laptop)

  
Actual results:
System wakes and screen-saver lock dialogue pops up but user is unable to input.
User must wait until the screen lock time-out occurs. Then when the dialogue pops up again, user is able to input.

Expected results:
user should be able to input without having to wait for the timeout

Additional info:
Comment 1 RHEL Product and Program Management 2010-05-21 07:35:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Chris Ward 2010-05-25 04:55:38 EDT
I just reproduced this again also using the following steps. 

1. boot system docked. 
2. Log-in
3. sleep system
4. Undock system
5. Wake system
6. Sleep system
7. Dock system
5. wake system
6. once screen-saver prompts for password, dock system
Comment 3 Chris Ward 2010-05-25 04:57:09 EDT
Arg. Sorry. Ignore comment #2.. (i'm slow today)

1. boot system docked. 
2. Log-in
3. sleep system
4. Undock system
5. Wake system
6. Sleep system
7. Dock system
8. wake system
9. once screen-saver prompts for password, notice how screensaver lock doesn't respond to keyboard / mouse input.
Comment 5 Chris Ward 2010-05-27 03:18:23 EDT
Thanks for the work on solving this William!!!
Comment 6 jmccann 2010-05-27 10:13:48 EDT
*** Bug 583661 has been marked as a duplicate of this bug. ***
Comment 7 jmccann 2010-06-04 15:26:33 EDT
*** Bug 577181 has been marked as a duplicate of this bug. ***
Comment 9 Michal Haško 2010-07-01 04:25:33 EDT
I am working on this to verify it.
Comment 10 Michal Haško 2010-07-02 10:17:40 EDT
VERIFIED

I was able to successfully unlock screen in all the scenarios below

    +----------+--------+---------+
    |          | LOCK & | SLEEP & |
    |          | RESUME | WAKE UP |
    +----------+--------+---------+
    |  DOCKED  |   ok   |    ok   |
    +----------+--------+---------+
    | UNDOCKED |   ok   |    ok   |
    +----------+--------+---------+

                               ACTIONS
    +----------+------------------+----------------+
    |          |   SLEEP DOCKED   | SLEEP UNDOCKED |
    |          | WAKE UP UNDOCKED | WAKE UP DOCKED |
    +----------+------------------+----------------+
D S | MIRRORED |        ok        |       ok       |
I E +----------+------------------+----------------+
S T | EXTENDED |        ok        |       ok       |
P T +----------+------------------+----------------+
L I | INTERNAL |        ok        |       ok       |
A N +----------+------------------+----------------+
Y G | EXTERNAL |        ok        |       ok       |
  S +----------+------------------+----------------+
Comment 11 releng-rhel@redhat.com 2010-11-10 15:31:50 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.