Bug 594711 - abrt kernel crash: WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x229/0x380()
Summary: abrt kernel crash: WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x22...
Keywords:
Status: CLOSED DUPLICATE of bug 593669
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 12:28 UTC by Mihai Harpau
Modified: 2010-05-23 02:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-23 02:18:03 UTC
Type: ---


Attachments (Terms of Use)

Description Mihai Harpau 2010-05-21 12:28:43 UTC
Description of problem:
I try to make an hibernate/resume cycle and I see this in abrt:

WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x229/0x380()
Hardware name: Latitude E5400                  
Modules linked in: fuse ipt_MASQUERADE iptable_nat nf_nat rfcomm sco bridge stp llc bnep l2cap sunrpc cpufreq_ondemand acpi_cpufreq freq_table xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 kvm_intel kvm uinput arc4 ecb snd_hda_codec_intelhdmi iwlagn snd_hda_codec_idt iwlcore snd_hda_intel snd_hda_codec sdhci_pci sdhci mmc_core snd_hwdep mac80211 snd_seq snd_seq_device snd_pcm snd_timer dell_wmi btusb snd bluetooth tg3 soundcore iTCO_wdt cfg80211 snd_page_alloc dell_laptop rfkill wmi iTCO_vendor_support i2c_i801 dcdbas joydev microcode firewire_ohci firewire_core crc_itu_t yenta_socket rsrc_nonstatic i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan]
Pid: 1154, comm: flush-253:2 Tainted: G        W  2.6.33.4-95.fc13.x86_64 #1
Call Trace:
[<ffffffff8104b558>] warn_slowpath_common+0x77/0x8f
[<ffffffff8104b57f>] warn_slowpath_null+0xf/0x11
[<ffffffff8111c3a7>] writeback_inodes_wb+0x229/0x380
[<ffffffff8111c63b>] wb_writeback+0x13d/0x1bc
[<ffffffff8109e283>] ? call_rcu_sched+0x10/0x12
[<ffffffff8109e28e>] ? call_rcu+0x9/0xb
[<ffffffff8111c7cf>] wb_do_writeback+0x69/0x14d
[<ffffffff8111c8ed>] bdi_writeback_task+0x3a/0xaa
[<ffffffff810d5cf8>] ? bdi_start_fn+0x0/0xd4
[<ffffffff810d5d64>] bdi_start_fn+0x6c/0xd4
[<ffffffff810d5cf8>] ? bdi_start_fn+0x0/0xd4
[<ffffffff810643c7>] kthread+0x7a/0x82
[<ffffffff8100a924>] kernel_thread_helper+0x4/0x10
[<ffffffff8106434d>] ? kthread+0x0/0x82
[<ffffffff8100a920>] ? kernel_thread_helper+0x0/0x10

Version-Release number of selected component (if applicable):
Fedora 13 RC3 up-to-date
kernel-2.6.33.4-95.fc13.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jesus M. Rodriguez 2010-05-22 14:00:54 UTC
same problem on my machine as well

Comment 2 Jesus M. Rodriguez 2010-05-22 14:01:28 UTC
WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x229/0x380()
Hardware name: 4384AT9
Modules linked in: fuse ipt_MASQUERADE iptable_nat nf_nat rfcomm sco bridge stp llc bnep l2cap sunrpc cpufreq_ondemand acpi_cpufreq freq_table xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 kvm_intel kvm uinput snd_hda_codec_intelhdmi snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device arc4 ecb thinkpad_acpi wmi snd_pcm iwlagn iwlcore uvcvideo mac80211 videodev cfg80211 v4l1_compat snd_timer btusb e1000e sdhci_pci iTCO_wdt v4l2_compat_ioctl32 snd sdhci i2c_i801 soundcore bluetooth mmc_core iTCO_vendor_support snd_page_alloc rfkill joydev microcode firewire_ohci firewire_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan]
Pid: 1212, comm: flush-253:2 Not tainted 2.6.33.4-95.fc13.x86_64 #1
Call Trace:
[<ffffffff8104b558>] warn_slowpath_common+0x77/0x8f
[<ffffffff8104b57f>] warn_slowpath_null+0xf/0x11
[<ffffffff8111c3a7>] writeback_inodes_wb+0x229/0x380
[<ffffffff8111c63b>] wb_writeback+0x13d/0x1bc
[<ffffffff8109e283>] ? call_rcu_sched+0x10/0x12
[<ffffffff8109e28e>] ? call_rcu+0x9/0xb
[<ffffffff8111c7cf>] wb_do_writeback+0x69/0x14d
[<ffffffff8111c8ed>] bdi_writeback_task+0x3a/0xaa
[<ffffffff810d5cf8>] ? bdi_start_fn+0x0/0xd4
[<ffffffff810d5d64>] bdi_start_fn+0x6c/0xd4
[<ffffffff810d5cf8>] ? bdi_start_fn+0x0/0xd4
[<ffffffff810643c7>] kthread+0x7a/0x82
[<ffffffff8100a924>] kernel_thread_helper+0x4/0x10
[<ffffffff8106434d>] ? kthread+0x0/0x82
[<ffffffff8100a920>] ? kernel_thread_helper+0x0/0x10

Comment 4 Jesus M. Rodriguez 2010-05-22 14:17:49 UTC
Recreation steps

* boot machine up normally (cold boot)
* use normally (browse, create files, etc)
* close laptop lid, observe the 'moon' icon light up
* after some time has past (minute, 30 minutes, even hours), open the lid again
* observe the laptop resumes successfully but abrt occurs showing kernel oops

[]$ rpm -q fedora-release
fedora-release-13-1.noarch

[]$ uname -a
Linux speed3.yyy.xxx.com 2.6.33.4-95.fc13.x86_64 #1 SMP Thu May 13 05:16:23 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Comment 5 Chuck Ebbert 2010-05-23 02:18:03 UTC

*** This bug has been marked as a duplicate of bug 593669 ***


Note You need to log in before you can comment on or make changes to this bug.