Bug 594759 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib64/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib64/firefox-3.5/firefox ...
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 12
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:452f6f1268be3b42624f0c4e5ed...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 14:14 UTC by Ralf Schneider
Modified: 2010-05-22 13:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-22 13:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (73.53 KB, text/plain)
2010-05-21 14:14 UTC, Ralf Schneider
no flags Details

Description Ralf Schneider 2010-05-21 14:14:46 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.5/firefox
comment: As described above, did nothing special but opening a website with flashing add banners
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/firefox-3.5/firefox
global_uuid: 452f6f1268be3b42624f0c4e5ed0115b8a412496
kernel: 2.6.32.12-115.fc12.x86_64
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib64/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.Open a website with fancy flashing adds
2.In this case the Top500.org
3.

Comment 1 Ralf Schneider 2010-05-21 14:14:49 UTC
Created attachment 415697 [details]
File: backtrace

Comment 2 Chris Campbell 2010-05-22 13:39:56 UTC
#2  <signal handler called>
No symbol table info available.
#3  0x000000310e025f5d in type_node_check_conformities_UorL (
    type_instance=0x7fa5db2ffec0, iface_type=<value optimized out>)
    at gtype.c:3195
        match = <value optimized out>
#4  type_node_conforms_to_U (type_instance=0x7fa5db2ffec0, 
    iface_type=<value optimized out>) at gtype.c:3228
No locals.
#5  IA__g_type_check_instance_is_a (type_instance=0x7fa5db2ffec0, 
    iface_type=<value optimized out>) at gtype.c:3697
        node = 0x7fa5db2ffce0
        iface = 0x7fa5e460d160
        check = 1
#6  0x00007fa5dba5f334 in swfdec_as_frame_set_this (frame=0x7fff33e9fb20, 
    thisp=0x7fa5db2ffec0) at swfdec_as_frame.c:347
        __t = 1
        __r = <value optimized out>
        __PRETTY_FUNCTION__ = "swfdec_as_frame_set_this"
#7  0x00007fa5dba6940e in swfdec_as_native_function_call (
    function=0x7fa5d03cfe20, thisp=0x7fa5db2ffec0, construct=0, 
    super_reference=<value optimized out>, n_args=3, 
    args=<value optimized out>, return_value=0x0)
    at swfdec_as_native_function.c:82
        native = 0x7fa5d03cfe20
        cx = 0x7fa5cfff8800
        frame = {next = 0x7fff33e9fd50, function = 0x7fa5d03cfe20, thisp = 0, 
          super = 0x0, construct = 0, return_value = 0x0, argc = 0, 
          argv = 0x0, script = 0x0, scope_chain = 0x0, block_start = 0x0, 
          block_end = 0xffffffffffffffff <Address 0xffffffffffffffff out of bounds>, blocks = 0x7fa5db6ae7c0, target = 0x0, original_target = 0x0, 
          activation = 0x0, registers = 0x0, n_registers = 0, 
          constant_pool = 0x0, stack_begin = 0x7fa5d051b028, pc = 0x0}
        rval = 0
        argv = <value optimized out>
        __PRETTY_FUNCTION__ = "swfdec_as_native_function_call"



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-05-22 13:47:30 UTC
Problem here occured in the swfdec flash plugin. Unfortunately, that plugin is no longer actively supported. Due to this, swfdec will no longer be included with Fedora, from Fedora 13 on.

You may continue to use swfdec and live with the problems, or uninstall it and use either the closed-source Adobe Flash plugin or one of the few other open-source Flash plugins.

Or, if you are a coder, perhaps you could take over updating/fixing swfdec... :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.