Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 594789 - Install to a system with encrypted partition blows up
Install to a system with encrypted partition blows up
Status: CLOSED DUPLICATE of bug 593487
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 11:58 EDT by Bill Burns
Modified: 2010-05-24 13:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 13:44:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Burns 2010-05-21 11:58:44 EDT
Description of problem:
Tried to install RHEL 6 onto a laptop that had an encrypted
root. Selected custom for disk and when it pops up
to prompt for the encryption key, the install crashed after
entering the key. 

Version-Release number of selected component (if applicable):
DVD install from:
RHEL6.0-20100512.n.0-Server-x86_64-DVD1.iso

How reproducible:
Happened twice, workd around by booting live CD and dd'ing
zeros to the encrypted partition.

Steps to Reproduce:
1. try to install to a system with an encrypted partition
2.
3.
  
Actual results:
install will traceback and crash.

Expected results:
should not fail

Additional info:
none
Comment 3 Chris Lumens 2010-05-21 15:52:28 EDT
Please attach the complete traceback to this bug report.
Comment 4 Bill Burns 2010-05-21 16:04:22 EDT
Cannot, it was on a graphic console, my laptop screen, no way to capture it. And it was newline challenged, a real mess. It is easily reproducible.
Comment 5 Bill Burns 2010-05-21 16:07:00 EDT
I should note it was on a t60 and was an x86_64 install.
Comment 6 Chris Lumens 2010-05-21 16:59:21 EDT
You can't take a picture and attach that?  Or switch to tty2 and grab /tmp/anaconda-tb-*?  What's easily reproducible for you is not necessarily easily reproducible for anyone else, as we don't have your exact hardware and preexisting partitioning configuration available.
Comment 7 Bill Burns 2010-05-23 22:12:43 EDT
Well it's my laptop and I need it. If you have tried it and it works, let me know and I will see what I can do.
Comment 8 Bill Burns 2010-05-24 13:44:14 EDT
closing as a dup...

*** This bug has been marked as a duplicate of bug 593487 ***

Note You need to log in before you can comment on or make changes to this bug.