Bug 594836 - Gnome Trashcan doesn't work on ext4 filesystems
Gnome Trashcan doesn't work on ext4 filesystems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
5.6
All Linux
low Severity low
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
:
: 633188 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 13:58 EDT by Phil Randal
Modified: 2015-03-03 17:48 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-vfs2-2.16.2-8.el5
Doc Type: Bug Fix
Doc Text:
Cause: new filesystems such as ext4 were unknown to gnome-vfs2 due to date of release Consequence: trashcan was not working properly Fix: support for commonly used modern filesystems was added in gnome-vfs2 Result: trashcan now works properly
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-13 16:14:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Minimal patch to add ext4 support (583 bytes, patch)
2010-11-10 16:16 EST, Phil Randal
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 590298 None None None Never
Debian BTS 539322 None None None Never

  None (edit)
Description Phil Randal 2010-05-21 13:58:58 EDT
Description of problem:

The Gnome Trashcan doesn't work on ext4 filesystems.

Version-Release number of selected component (if applicable):

gnome-vfs2-2.16.2-6.el5

How reproducible:

Always

Steps to Reproduce:
1. Mount any filesystem as ext4
2. Drag a file from ext4 filesystem to desktop trashcan
3.
  
Actual results:

No change to trashcan - empty trashcan still appears empty

Expected results:

Deleted file should show in Trash

Additional info:

This has already been noted by Debian:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=539322

and fixed upstream

http://bugzilla.gnome.org/show_bug.cgi?id=590298

I've verified that applying the fix in the upstream patch fixes the issue.
Comment 1 Phil Randal 2010-05-21 14:05:07 EDT
I've also discussed it here:

https://www.centos.org/modules/newbb/viewtopic.php?topic_id=26349
Comment 2 Phil Randal 2010-05-21 14:23:45 EDT
Step 1 should of course read:

1: Mount any ext4 filesystem
Comment 5 RHEL Product and Program Management 2010-08-09 15:04:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Tomáš Bžatek 2010-09-14 05:13:09 EDT
*** Bug 633188 has been marked as a duplicate of this bug. ***
Comment 7 Phil Randal 2010-11-10 16:16:15 EST
Created attachment 459545 [details]
Minimal patch to add ext4 support

This bug still isn't fixed in 5.6 beta.

Attached patch is minimal fix for ext4; there may be other file systems which should be added.
Comment 8 Phil Randal 2010-11-10 16:24:49 EST
This bug needs to be fixed before RedHat 5.6 final release.

Note in particular http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/5.6_Release_Notes/ar01s05.html

"The fourth extended filesystem (ext4) is now a fully supported feature in Red Hat Enterprise Linux 5.6"

Without this fixed, the above statement will be patently untrue.
Comment 9 Tomáš Bžatek 2010-11-11 06:15:02 EST
(In reply to comment #8)
> This bug needs to be fixed before RedHat 5.6 final release.
Phil, please go through our official support if you still need this in 5.6 release.
Comment 10 Phil Randal 2010-11-11 06:20:26 EST
It's not just me.  I can roll my own fixes.

Any user who uses ext4 and Gnome Desktop in 5.6 would be bitten by this.

It's a bug, the fix is simple.

Just do it.
Comment 11 Tomáš Bžatek 2010-11-11 07:10:10 EST
For official Red Hat Enterprise Linux support, please log into the Red Hat support website at http://www.redhat.com/support and file a support ticket. To understand how your bug is tracked through our system, please see https://www.redhat.com/support/process/production/#howrh
Comment 12 Taunus 2010-12-03 08:25:56 EST
What is this bugzilla for? Filing for bugs which never get fixed? Why do you even have Redhat Enterprise Linux here as an option for reports?

If you prefer to bit rot your beloved operating system then please go ahead. I can stop filing tickets too.

Sorry but I simply cannot understand your reasoning. Is this really the company policy?

Maybe I should throw the rhel DVD's in the trash... But oh, I cant, it is not working!
Comment 13 Taunus 2011-01-10 06:21:46 EST
Please remove the Comment 12, it is a bad joke. Sorry about that.
Comment 15 Tomáš Bžatek 2011-03-29 10:12:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: new filesystems such as ext4 were unknown to gnome-vfs2 due to date of release

Consequence: trashcan was not working properly

Fix: support for commonly used modern filesystems was added in gnome-vfs2

Result: trashcan now works properly
Comment 18 errata-xmlrpc 2011-04-13 16:14:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0441.html

Note You need to log in before you can comment on or make changes to this bug.