Bug 59485 - rpm shouldn't check *all* filesystems for size
Summary: rpm shouldn't check *all* filesystems for size
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-08 21:01 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-08 21:01:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-02-08 21:01:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.17 i686; Nav)

Description of problem:
RPM should check only the filesystems that are going to have files installed on
them for enough size.  Currently, if one has a slow smbfs mount, one is either
stuck with using --ignoresize or waiting...and waiting...and waiting while the
size of all mounted filesystems is examined.

Version-Release number of selected component (if applicable):
rpm-4.0.3-1.03

How reproducible:
Always

Steps to Reproduce:
Mount a slow smbfs mount, and run rpm -Uvh <rpmname>.  If other i/o is going on
on the filesystem, things become even more unbearable.

Actual Results:  rpm waits and waits on examining the smbfs filesystem size

Expected Results:  rpm should have skipped checking the smbfs filesystem size,
since no files were being installed on that filesystem.

Additional info:

rpm-4.0.3-1.03

Comment 1 Jeff Johnson 2002-02-08 22:42:50 UTC
rpm has to check all mounted file systems for file paths, or disk accounting
doesn't "work". There's no way to tell a priori where the files
in a package are gonna end up, nor is it possible to take into
account in packaging, all possible types of file system mount points.

What may be a bit subtle, is that rpm also does disk accounting
through all file system symlinks, even if the symlink points to, say, another
mounted files system.

Use --ignoresize if necessary, that's what the option is there for.


Note You need to log in before you can comment on or make changes to this bug.