Bug 594855 - virtual console echos passwd during init 3 boot..
Summary: virtual console echos passwd during init 3 boot..
Keywords:
Status: CLOSED DUPLICATE of bug 586040
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Karel Zak
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 19:30 UTC by john cooper
Modified: 2014-07-25 03:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-21 19:44:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description john cooper 2010-05-21 19:30:12 UTC
Description of problem:

The tty mode of the virtual console appears out of kilter
during an init 3 boot of rhel6 beta resulting in suppressed
echo of username and unexpected echo of the user's passwd.
Other issues also exist as apparently canonical tty processing
is also disabled.

Version-Release number of selected component (if applicable):

rhel6.0 beta 20100428.3

How reproducible:

Set /etc/inittab to default boot to run level 3.
Attempt to login to virtual console.

Steps to Reproduce:
1. (as above)
2.
3.
  
Actual results:

(as above)

Expected results:

username/passwd should/shouldn't echo.  tty processing
should behave normally.

Additional info:

Note this was seen running as a guest so there is
some chance it relates to a qemu issue.  Didn't
have the opportunity to attempt reproducing on a
metal install.

Comment 1 Bill Nottingham 2010-05-21 19:44:06 UTC

*** This bug has been marked as a duplicate of bug 586040 ***


Note You need to log in before you can comment on or make changes to this bug.