Bug 59489 - mkfontdir is failed dependency
mkfontdir is failed dependency
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 16:30 EST by sean
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-08 16:30:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2002-02-08 16:30:30 EST
Description of Problem:
XFree86-4.2.0-6.24 fails to install because it can't find mkfontdir - even if
it's there:

root@localhost i386]# rpm -Fvh XFree*
error: failed dependencies:
	/usr/X11R6/bin/mkfontdir   is needed by XFree86-100dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by XFree86-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by XFree86-75dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by XFree86-base-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by
XFree86-ISO8859-15-100dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by
XFree86-ISO8859-15-75dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by
XFree86-ISO8859-2-100dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by
XFree86-ISO8859-2-75dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by
XFree86-ISO8859-9-100dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by
XFree86-ISO8859-9-75dpi-fonts-4.2.0-6.24
	/usr/X11R6/bin/mkfontdir   is needed by XFree86-xfs-4.2.0-6.24

Isn't mkfontdir provided by XFree-xfs?

Anyway, I rebuilt the src.rpm using  rpm -bc. mkfontdir is built (without any
errors). I copied it to /usr/X11/bin.

[root@localhost i386]# ls /usr/X11R6/bin/mkfont*
/usr/X11R6/bin/mkfontdir

Still the same result from rpm -Fvh.

Do I just -nodeps?



Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. rpm -Fvh XFree
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Mike A. Harris 2002-02-08 17:58:31 EST
Your RPM command failed, because it is incorrect.
You need to download all of the XFree86 rpm's, and then use:

rpm -Uvh XFree86-*.rpm

mkfontdir has moved from the XFree86-xfs subpackage to the
XFree86-font-utils subpackage, so that you do not need to install
or use xfs to get mkfontdir and ttmkfdir to install fonts.

rpm -Fvh only upgrades packages which are installed already, and
since XFree86-font-utils is not installed already, the xfs package
that is on your system that contains mkfontdir, gets replaced with
the new one without mkfontdir, the dependancy is no longer met.




Note You need to log in before you can comment on or make changes to this bug.