Bug 59491 - invalidate: busy buffer
invalidate: busy buffer
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 16:48 EST by Jeremy Katz
Modified: 2007-04-18 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 08:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2002-02-08 16:48:02 EST
On all of our post 2.4.9 era kernels, running parted on disks which have mounted
partitions even just for reading results in *many* messages of invalidate: busy
buffer.  In some cases, you just get the spewage to syslog for 5-10 seconds and
nothing more (no biggie other than confusing people).  In others, though, I've
had my laptop sit hard locked for a minute or more giving no response while
spewing several thousand instances of the message.
Comment 1 Arjan van de Ven 2002-02-19 12:39:28 EST
2 parts in this bug:
1) partitioning while live fs mounted: not supported
2) the busy buffers in case of no longer live.... do you know if it helps if you
"sync" inbetween unmounting and  the invalidate ?
Comment 2 Jeremy Katz 2002-02-19 18:39:56 EST
But I'm not really repartitioning.  Parted is just doing the reading of the
disks to get this to happen (run parted /dev/hda; print).  It's the parted
equivalent of fdisk -l, and if that's not supported, it's not going to be
exactly nice :(

I'll take a look at seeing what interaction changes I can get by doing some
syncing as well as fsck'ing my disk to see if that helps since it seems a lot
worse on my laptop than my desktop.
Comment 3 giulioo 2002-03-15 15:09:16 EST
beta2, Linux pc17 2.4.18-0.1 #1 Wed Feb 27 07:42:03 EST 2002 i686 unknown
http://www.beta.redhat.com/betahardware.cgi?action=form&id=6

I get many of these, always after something load parport automatically (also 
note "try to free nonexistent resource":

Mar 13 17:08:40 pc17 gconfd (root-1247): Unable to open saved state file '/root/
.gconfd/saved_state': No such file or directory
Mar 13 17:08:53 pc17 xinetd[1260]: warning: can't get client address: Transport
endpoint is not connected
Mar 14 15:13:27 pc17 kernel: parport0: PC-style at 0x278 (0x678) [PCSPP,TRISTATE
,EPP]
Mar 14 15:13:27 pc17 kernel: parport0: irq 5 detected
Mar 14 15:13:30 pc17 kernel: invalidate: busy buffer
Mar 14 15:13:39 pc17 last message repeated 1008 times
Mar 14 15:13:39 pc17 kernel: invalidate: dirty buffer
Mar 14 15:13:39 pc17 kernel: invalidate: busy buffer
Mar 14 15:13:39 pc17 kernel: invalidate: dirty buffer
Mar 14 15:13:39 pc17 kernel: invalidate: busy buffer
Mar 14 15:13:39 pc17 kernel: invalidate: dirty buffer
Mar 14 15:13:39 pc17 kernel: invalidate: busy buffer
Mar 14 15:13:46 pc17 last message repeated 1213 times

.... 

Mar 15 17:07:53 pc17 kdm[994]: Rereading access file /etc/X11/xdm/Xaccess
Mar 15 17:08:19 pc17 kde(pam_unix)[1430]: session opened for user root by (uid=0
)
Mar 15 17:08:20 pc17 xinetd[1569]: warning: can't get client address: Transport
endpoint is not connected
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-slot-0
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-service-0-3
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-slot-0
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-service-0-0
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-slot-0
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-service-0-0
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-slot-1
Mar 15 17:08:25 pc17 modprobe: modprobe: Can't locate module sound-service-1-0
Mar 15 17:08:26 pc17 modprobe: modprobe: Can't locate module sound-slot-1
Mar 15 17:08:26 pc17 modprobe: modprobe: Can't locate module sound-service-1-0
Mar 15 17:09:34 pc17 kernel: parport0: PC-style at 0x278 (0x678) [PCSPP,TRISTATE
,EPP]
Mar 15 17:09:34 pc17 kernel: parport0: irq 5 detected
Mar 15 17:09:35 pc17 kernel: invalidate: busy buffer
Mar 15 17:09:37 pc17 last message repeated 15982 times
Mar 15 17:12:40 pc17 kernel:  hdc: unknown partition table
Mar 15 17:12:40 pc17 modprobe: modprobe: Can't locate module block-major-33
Mar 15 17:12:40 pc17 modprobe: modprobe: Can't locate module block-major-33
Mar 15 17:12:40 pc17 modprobe: modprobe: Can't locate module block-major-34
Mar 15 17:12:40 pc17 modprobe: modprobe: Can't locate module block-major-34
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-56
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-56
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-57
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-57
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-88
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-88
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-89
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-89
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-90
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-90
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-91
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-91
Mar 15 17:12:41 pc17 modprobe: modprobe: Can't locate module block-major-80
Mar 15 17:12:42 pc17 modprobe: modprobe: Can't locate module block-major-45
Mar 15 17:12:42 pc17 modprobe: modprobe: Can't locate module block-major-72
Mar 15 17:12:42 pc17 modprobe: modprobe: Can't locate module block-major-48
Mar 15 17:12:42 pc17 kernel: XD: Loaded as a module.
Mar 15 17:12:42 pc17 kernel: Trying to free nonexistent resource <00000320-00000
323>
Mar 15 17:12:42 pc17 insmod: /lib/modules/2.4.18-0.1/kernel/drivers/block/xd.o:
init_module: Operation not permitted
Mar 15 17:12:42 pc17 insmod: Hint: insmod errors can be caused by incorrect modu
le parameters, including invalid IO or IRQ parameters
Mar 15 17:12:42 pc17 insmod: /lib/modules/2.4.18-0.1/kernel/drivers/block/xd.o:
insmod block-major-13 failed
Mar 15 17:12:43 pc17 kernel:  hdc: unknown partition table
Mar 15 17:12:43 pc17 kernel: ide-scsi: hdd: unsupported comman
Comment 4 Philip Pokorny 2002-04-11 23:50:10 EDT
I'm using 2.4.18-0.13 BETA kernel and get tons of "invalidate: busy buffer"
errors when shutting down, not during startup.  It's very repeatable.  Happens
every time I shut down.  This box has 1G of memory and I'm not doing any "work"
on the box, so it's possible that no dirty pages are being written to disk until
shutdown.

I have software RAID configured with two drives hda, hdc.

Looking at the code in fs/buffer.c, we could get a lot more information that
might be helpful.  kdev, bh, bh->count.  I can recompile and print some
additional info.  What should I collect?

Or is this a different problem?
Comment 5 Stephen Tweedie 2002-04-12 13:23:02 EDT
Should be fixed in our internal tree now: look for it in a subsequent rawhide
kernel build.

Note You need to log in before you can comment on or make changes to this bug.