Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594911 - assertion `slot_id >= 1' failed when using PKCS#11 compliant library [NEEDINFO]
assertion `slot_id >= 1' failed when using PKCS#11 compliant library
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdm (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 18:03 EDT by Roy Keene
Modified: 2014-06-02 09:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (roy.keene)


Attachments (Terms of Use)

  None (edit)
Description Roy Keene 2010-05-21 18:03:31 EDT
Description of problem:

GDM does not support PKCS#11 drivers that return a Slot ID of 0.  This is valid per the PKCS#11 specification.

# gdm-binary --nodaemon
PKCS11_Driver:C_GetFunctionList():5510: Called.
PKCS11_Driver:C_GetFunctionList():5594: Returning CKR_OK (0)
PKCS11_Driver:C_Initialize():2897: Called.
PKCS11_Driver:C_Initialize():2957: Returning CKR_OK (0)
PKCS11_Driver:C_GetInfo():3006: Called.
PKCS11_Driver:C_GetInfo():3034: Returning CKR_OK (0)
PKCS11_Driver:C_GetSlotList():3051: Called.
PKCS11_Driver:C_GetSlotList():3132: Found reader: Dell smart card reader keyboard 00 00
PKCS11_Driver:C_GetSlotList():3172: Returning CKR_OK (0)
PKCS11_Driver:C_GetSlotList():3051: Called.
PKCS11_Driver:C_GetSlotList():3132: Found reader: Dell smart card reader keyboard 00 00
PKCS11_Driver:C_GetSlotList():3190: Returning CKR_OK (0).  Found 1 readers.
PKCS11_Driver:C_GetSlotInfo():3202: Called.
PKCS11_Driver:C_GetSlotInfo():3267: Returning CKR_OK (0)

** (process:4880): CRITICAL **: _sc_security_token_new: assertion `slot_id >= 1' failed



Version-Release number of selected component (if applicable):


How reproducible:
100%.

Steps to Reproduce:
1. Create PKCS#11 driver that returns slots with a handle ID of 0 when asked for C_GetSlotList()
2. Configure GDM to talk to PKCS#11 Driver
3. Start GDM
  
Actual results:
gdm issues an failed assertion.

Expected results:
gdm uses the library.

Additional info:
Submitted bug to GDM, they indicated that this is a RHEL problem:
https://bugzilla.gnome.org/show_bug.cgi?id=619297
Comment 1 RHEL Product and Program Management 2014-03-07 08:42:24 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:16:54 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.