Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594923 - nm-applet does not display signal strength when connected
nm-applet does not display signal strength when connected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 19:47 EDT by Alex
Modified: 2011-02-24 00:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 00:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the ouput of cat /var/log/messages | grep "Network" (15.21 KB, text/plain)
2010-05-25 19:55 EDT, Alex
no flags Details

  None (edit)
Description Alex 2010-05-21 19:47:15 EDT
Description of problem:
When connected to my home network nm-applet changes icons as it connects, but once connected displays the not connected icon.

Although at on my internet at work it displays the correct icon with signal strength

Version-Release number of selected component (if applicable):
Fedora 13

How reproducible:
So far only on my home network (which is encrypted with WPA-2) work is encrypted with enterprise PEAP 


Steps to Reproduce:
1.Connect to the network
2.Watch the icon change as it connects
3.The icon returns to its original not connected one
  
Actual results: Wrong icon when connected


Expected results: Signal strength icon


Additional info: Tried running nm-applet from the command line, but it did not produce any output, there is no man page for nm-applet or network manager and -v did not enable a verbose output
Comment 1 Dan Williams 2010-05-22 12:43:45 EDT
What version of NetworkManager are you using?  If you open a Terminal (Applications menu, then System Tools, then Terminal) and type 'rpm -q NetworkManager' that will tell you.

There was a bug in previous versions of NM for F13 that would cause connections to fail like you describe.  This bug was fixed in this version of NetworkManager:

NetworkManager-0.8-12.git20100504

or later.
Comment 2 Alex 2010-05-22 14:11:29 EDT
The output of rpm -q NetworkManager is

NetworkManager-0.8.1-0.1.git20100510.fc13.i686

I am using all the latest packages available in fedora 13
Comment 3 Dan Williams 2010-05-24 16:23:10 EDT
Ok, could you reproduce the problem and then attach your /var/log/messages file so that we can debug further?  Thanks!
Comment 4 Alex 2010-05-25 19:55:23 EDT
Created attachment 416584 [details]
Here is the ouput of cat /var/log/messages | grep "Network"
Comment 5 Dan Williams 2010-05-26 06:10:30 EDT
So the icon that's displayed in the problem case is the signal strength bars, but it appears as though none of the bars are filled and the signal strength is 0%?  Or just screenshot your desktop, crop to the applet, and attach the picture here if you like.  Thanks!
Comment 6 Alex 2010-05-26 07:39:01 EDT
Sorry not near that computer to crop a picture, but what happens is, once it is connected the icon goes back to the initial one, which is "there are networks available but you are not connected to any" the two computers monitors with an X in the bottom.

I can confirm that this occurs with the kmod-wl driver on fedora and the STA driver on ubuntu. It happens with my BCM 4315 broadcom wireless card, and only when accessing my linksys router, no others. And I can also confirm with the same driver in fedora 12 and ubuntu 9.10 it did not happen.
Comment 7 Dan Williams 2010-05-26 13:12:44 EDT
The logs from comment #4 don't indicate that though...  they indicate a successful connection at "May 25 18:21:51" and then the logs end without indicating a disconnection which would cause that icon.

Can you still ping sites and access web pages when this happens?
Comment 8 Alex 2010-05-26 13:17:55 EDT
Yes my internet works fine, it is just the icon that appears once I connect that is wrong, for some reason Network Manager must think my laptop is not connected when it really is
Comment 9 Dan Williams 2010-05-26 15:20:27 EDT
Just to confirm, when this happens, can you grab the output of 'nm-tool' for me?
Comment 10 Dan Williams 2010-05-26 15:57:05 EDT
Nevermind, found and fixed upstream as:

988e2ce74fdfbd013709498c34d5924d30aed4e3

of course since you're using the Broadcom proprietary driver you won't get any signal strength in this case (the driver has well-known bugs in that area which trigger the "roaming to (none)" thing) but at least you won't get the 'disconnected' icon any more.
Comment 11 Dan Williams 2011-02-24 00:12:56 EST
Should be long fixed in 0.8.1 and later in updates.

Note You need to log in before you can comment on or make changes to this bug.