Bug 594939 - [Console] Enhance Feature: ACI editing dialog initial size is not big enough to display all elements
Summary: [Console] Enhance Feature: ACI editing dialog initial size is not big enough ...
Status: CLOSED DUPLICATE of bug 706258
Alias: None
Product: 389
Classification: Retired
Component: Directory Console
Version: 1.2.8
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
: 625327 654478 (view as bug list)
Depends On:
Blocks: 434915
TreeView+ depends on / blocked
 
Reported: 2010-05-22 05:02 UTC by Yi Zhang
Modified: 2018-11-14 16:56 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-06-07 05:00:15 UTC


Attachments (Terms of Use)
original dialog size (some elements are not visible) (335.06 KB, image/png)
2010-05-22 05:02 UTC, Yi Zhang
no flags Details
enlarged dialog , we can see all UI elements (331.31 KB, image/png)
2010-05-22 05:03 UTC, Yi Zhang
no flags Details
I couldn't re-produce the problem, it looks fine to me again even i removed the cached jars (117.51 KB, image/png)
2010-05-22 08:15 UTC, Yi Zhang
no flags Details
Patch (1.73 KB, patch)
2011-02-19 03:36 UTC, Nathan Kinder
nhosoi: review+
Details | Diff

Description Yi Zhang 2010-05-22 05:02:16 UTC
Created attachment 415821 [details]
original dialog size (some elements are not visible)

Description of problem:
When user get into ACI editing dialog, some UI elements are not visible to user. User has enlarge it to see all provided features. 

Please check out the screen shots. 

Version-Release number of selected component (if applicable):8.2


How reproducible: always


Steps to Reproduce:
1. Setup DS and Admin server
2. Install console
3. launch and log into console -> go to: Directory Panel -> Directory Tab -> Pick "People" subtree, such as idm-> People -> right click menu: "Set Access Permissions..." -> on the pop up dialog "Manage Access Control for ou=People,dc=idm...." Click "New" -> and we will see it
  
Actual results:


Expected results:


Additional info:
This might happens in previous version as well.

Comment 1 Yi Zhang 2010-05-22 05:03:07 UTC
Created attachment 415822 [details]
enlarged dialog , we can see all UI elements

Comment 2 Yi Zhang 2010-05-22 08:15:45 UTC
Created attachment 415836 [details]
I couldn't re-produce the problem, it looks fine to me again even i removed the cached jars

Comment 4 Yi Zhang 2010-06-18 18:39:41 UTC
Here is a new issue relate to this one that discovered by Chandra

-- first of all, this is re-producible, the trick is that you have to click "Edit..." on the right instead of "New.." button
 
-- continue for my reported re-produce step, as we see from the attached picture, we have a pretty large window. If we go one step further, close this window and click the "Edit..." (the same button) again, we will get a even larger  window -- the window is too long that you wont' see the bottom. In fact, Chandra and me tried to resize the window to make it smaller. We kept trying it for many times, we couldn't see the bottom of this window. It looks like infinity long to us. 

-- and the bottom of this window is flicking at Chandra's test -- not at my test

-- we both use RHEL 5 64bit
-- I tried RHEL 4 64bit, it works fine

Comment 8 Rich Megginson 2011-02-01 18:00:44 UTC
*** Bug 654478 has been marked as a duplicate of this bug. ***

Comment 9 Nathan Kinder 2011-02-19 03:36:59 UTC
Created attachment 479641 [details]
Patch

The problem had to do with the preferred size of the JTextArea that holds the ACI name having an unusually large height.  The JTextArea had line wrapping enabled, yet it's default size was not set.  This was resulting in it thinking that it needed a huge height due to a lot of text wrapping.

The fix is to set the initial rows and columns of the text area when we call it's constructor and to contain the text area in a scrollable pane.  This results in a sane preferred size and allows a long ACI name to line wrap properly.

Comment 10 Nathan Kinder 2011-02-21 17:50:12 UTC
Checked into console (HEAD).  Thanks to Noriko for her review!

Checking in src/com/netscape/management/client/ace/ACIEditor.java;
/cvs/dirsec/console/src/com/netscape/management/client/ace/ACIEditor.java,v  <--  ACIEditor.java
new revision: 1.3; previous revision: 1.2
done

Comment 12 Chandrasekar Kannan 2011-03-14 20:59:01 UTC
*** Bug 625327 has been marked as a duplicate of this bug. ***

Comment 13 Amita Sharma 2011-05-24 08:09:01 UTC
I am hitting the same bug...

While testing this at my console, I am facing exactly same issue what is reported in Comment#4

-- first of all, this is re-producible, the trick is that you have to click
"Edit..." on the right instead of "New.." button - 

Yes Same in my case

-- continue for my reported re-produce step, as we see from the attached
picture, we have a pretty large window. If we go one step further, close this
window and click the "Edit..." (the same button) again, we will get a even
larger  window -- the window is too long that you wont' see the bottom. In
fact, Chandra and me tried to resize the window to make it smaller. We kept
trying it for many times, we couldn't see the bottom of this window. It looks
like infinity long to us.  -

 Exactly same in my case

-- and the bottom of this window is flicking at Chandra's test -- not at my
test

The warning message at the bottom of the window was blinking till it got disappeared and after few seconds I got the large window which I was not able to reduce in size.

-- we both use RHEL 5 64bit
I am using -
Red Hat Enterprise Linux Server release 6.0 (Santiago) - 64 bit
and
[root@testvm slapd-testvm]# rpm -qa | grep 389
389-adminutil-1.1.13-1.el6.x86_64
389-console-1.1.4-1.el6.noarch
389-admin-console-1.1.7-1.el6.noarch
389-ds-base-libs-1.2.8.2-1.el6_1.1.x86_64
389-admin-1.1.16-2.el6.x86_64
389-ds-console-1.2.5-1.el6.noarch
389-ds-base-1.2.8.2-1.el6_1.1.x86_64


-- I tried RHEL 4 64bit, it works fine

Comment 14 Rich Megginson 2011-06-06 22:43:29 UTC
Is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=706258 ?  If so, please close it as a duplicate

Comment 16 Amita Sharma 2011-06-07 05:00:15 UTC
(In reply to comment #14)
> Is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=706258 ?  If
> so, please close it as a duplicate

yes, It is duplicate of  https://bugzilla.redhat.com/show_bug.cgi?id=706258, hence I am closing it.

*** This bug has been marked as a duplicate of bug 706258 ***


Note You need to log in before you can comment on or make changes to this bug.