Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594965 - fails to download episodes due to parse error
fails to download episodes due to parse error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-22 06:18 EDT by pleabargain
Modified: 2010-06-29 04:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 04:01:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (53.56 KB, text/plain)
2010-05-22 06:18 EDT, pleabargain
no flags Details
rhythmbox -d output (36.81 KB, text/plain)
2010-05-22 06:20 EDT, pleabargain
no flags Details
rbox started dnlding after reboot but died seconds later: download failed: here is the lsof (509.72 KB, application/octet-stream)
2010-05-24 10:30 EDT, pleabargain
no flags Details

  None (edit)
Description pleabargain 2010-05-22 06:18:05 EDT
Created attachment 415846 [details]
dmesg

Description of problem:
fails to download episodes due to parse error

Version-Release number of selected component (if applicable):
rpm -qa rhythmbox ; uname -r
rhythmbox-0.12.6-5.fc12.i686
2.6.32.12-115.fc12.i686


How reproducible:
everytime

Steps to Reproduce:
1.launch Rbox
2.try to dnld podcast
3.
  
Actual results:
fail

Expected results:
work

Additional info:
rpm -qa rhythmbox ; uname -r
rhythmbox-0.12.6-5.fc12.i686
2.6.32.12-115.fc12.i686


Please see video.
Comment 1 pleabargain 2010-05-22 06:20:51 EDT
Created attachment 415848 [details]
rhythmbox -d output

Trying to capture why rbox is not working anymore... it DID work before.
Comment 2 pleabargain 2010-05-22 06:31:39 EDT
Here's the vid
http://www.youtube.com/watch?v=Z2xoRS2Sumg
Comment 3 Bastien Nocera 2010-05-24 05:31:32 EDT
Something on your system is leaking files descriptors:
(13:07:52) [0x8a34038] [download_error] rb-podcast-manager.c:623: error
downloading http://media.theworld.org/pod/best/best09.mp3: DBus error
org.gtk.vfs.Error.SocketFailed: Failed to create new socket: Failed to open
socket: Too many open files

Check the output of lsof to see what the culprit is.
Comment 4 pleabargain 2010-05-24 10:30:00 EDT
Created attachment 416142 [details]
rbox started dnlding after reboot but died seconds later: download failed: here is the lsof

I don't know what to look for here so I am not sure the culprit.
All help appreciated.
Comment 5 pleabargain 2010-06-29 04:01:56 EDT
Working now. Don't know why. Closing

Note You need to log in before you can comment on or make changes to this bug.