Bug 594999 - Summary and Description are old-fashioned
Summary and Description are old-fashioned
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netatalk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-22 13:16 EDT by HAT
Modified: 2014-11-09 17:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 04:13:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Renaming initscript, POSIX compliance (3.13 KB, patch)
2010-05-26 05:17 EDT, Jiri Skala
no flags Details | Diff

  None (edit)
Description HAT 2010-05-22 13:16:56 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 HAT 2010-05-22 13:24:04 EDT
Summary and Description are old-fashioned.
AppleTalk is already disabled by default.

BTW,
Netatalk team consult Fedora packagers.
We will change initscript's name from "atalk" to "netatalk".
A keyword "atalk" is an abbreviation for "AppleTalk".

from:
/etc/rc.d/init.d/atalk
to:
/etc/rc.d/init.d/netatalk

Do you have the objection in this?
Comment 2 Jiri Skala 2010-05-24 06:55:28 EDT
This shouldn't be a problem. Do you plan to release new tarball with renamed initscript?
Comment 3 HAT 2010-05-24 10:38:46 EDT
Our policy follows the opinion of the packagers.
We never change the name for Fedora/RedHat.

It has already changed to "netatalk" for Solaris and Debian.
These have followed the opinion of specialist.
Comment 4 Jiri Skala 2010-05-26 05:17:34 EDT
Created attachment 416721 [details]
Renaming initscript, POSIX compliance

I've made attached patch that renames atalk -> netatalk and there are additional changes due to POSIX compliance - two kind of changes:

- correct exit codes when something is wrong (e.g. no conf file, ...)
- tests moved to starting fce

Summary proposal: Daemon providing Apple Protocol Suite for BSD-derived systems
Description proposal (used from sourceforge.net):
Netatalk is a daemon which provides POSIX-compliant *NIX/*BSD systems with the ability to share files and printers with Apple Macintosh computers.

Any objection?

Jiri
Comment 5 HAT 2010-05-27 12:04:25 EDT
Hi,

--------------------------------------------------

>-sysvdir        = $(DESTDIR)/etc/rc.d/init.d
>+sysvdir        = /etc/rc.d/init.d

This is already fixed in netatalk 2.1.1.
See NEWS file in netatalk 2.1.1 taball.

>Changes in 2.1.1
>* FIX: DESTDIR support: DESTDIR was expanded twice

--------------------------------------------------

>-ATALK_BIN=:BINDIR:
>-ATALK_CONF_DIR=:ETCDIR:
>-ATALK_SBIN=:SBINDIR:
>+ATALK_BIN=/usr/bin
>+ATALK_CONF_DIR=/etc/atalk/
>+ATALK_SBIN=/usr/sbin

These are not needed because all of these can be specified at
configure time.

I think /etc/netatalk is better than /etc/atalk.
What do you think?

--------------------------------------------------

>Summary proposal:
>Daemon providing Apple Protocol Suite for BSD-derived systems
>
>Description proposal (used from sourceforge.net):
>Netatalk is a daemon which provides POSIX-compliant *NIX/*BSD systems
>with the ability to share files and printers with Apple Macintosh
>computers.

I think it is enough.
Please refer to the following sentences.

http://sourceforge.net/projects/netatalk/

netatalk is a daemon which provides POSIX-compliant *NIX/*BSD systems with the ability to share files and printers with Apple Macintosh computers.


http://netatalk.sourceforge.net/

Netatalk is a freely-available Open Source AFP fileserver. It also provides a kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system running Netatalk is capable of serving
many Macintosh clients simultaneously as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server, and for accessing AppleTalk printers via Printer Access Protocol (PAP). Included
are a number of minor printing and debugging utilities.

distrib/initscripts/rc.atalk.redhat.tmpl

# description: This package is an implementation of "AFP over TCP"
#              and provides printer, file sharing, and routing
#              services via legacy AppleTalk networking protocol.


distrib/initscripts/rc.atalk.suse.tmpl

# Description:    AFP over TCP and legacy Appletalk daemons

Note You need to log in before you can comment on or make changes to this bug.