This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 5950 - Need up to date tulip driver in installer
Need up to date tulip driver in installer
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-14 09:26 EDT by clemons
Modified: 2015-01-07 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 13:17:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description clemons 1999-10-14 09:26:41 EDT
When attempting a kickstart install on new machines with a
Kingston 10/100 Mbps card, the tulip driver loads but fails
to actually work with the card.  I notice that version .89H
of the tulip driver is loaded -- I've also confirmed that a
more recent version, .91, works correctly for this card.
Could we please see this driver updated in the next release
of the installers?  Thank you.
Comment 1 Bill Nottingham 1999-10-14 11:45:59 EDT
*** Bug 5842 has been marked as a duplicate of this bug. ***

For both Red Hat Linux 6.0 and 6.1, you've included the
0.89H version of the tulip driver by Donald Becker.  You
have also listed on your Tier 1 supported NIC page "Digital
21x4x Tulip PCI ethernet cards".  However, I have a card
made by Kingston that won't work with the older driver.  The
card is a KNE100TX and is has a 21143 chip on it.  Upgrading
to the 0.91 series of tulip drivers solved the problem for
me.  However, your inclusion of the older driver prohibits
me from installing via a network and I have to burn a CD and
then recompile my kernel after installation.  Its doable but
it would be far more pleasant to install from the network.
Please consider upgrading the driver version for the tulip
module.  Also, its not clear if "Digital 21x4x Tulip PCI
ethernet cards" is a generic term covering that chipset or
if its specific to cards made by Digital.  If the former,
then this is definitely an "errata" item.  If the latter,
then I guess I fall under the "Not listed, not supported"
category
Comment 2 Bill Nottingham 1999-10-14 11:53:59 EDT
Unfortunately, the 0.91 driver breaks on some of the cards that the
0.89 driver works on.
Comment 3 clemons 1999-10-14 12:17:59 EDT
If this is the case, then some flexibility with the installer images
is required.  I've tried unpacking the bootnet.img and replacing the
tulip driver but this fails due to the version discrepency with the
kernel.  Would it be possible for the install program to call insmod
with the -f flag to allow for a more forgiving installer?
Comment 4 Bill Nottingham 1999-10-14 14:13:59 EDT
Actually, that would probably still die, due to the symbols
not matching.

You could compile the module for the boot kernel and it would work
OK. If you have a stock install, it would be something like:

gcc -D__BOOT_KERNEL_BOOT=1 -D__KERNEL__ -I/usr/src/linux/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing
-pipe -fno-strength-reduce -m386 -DCPU=386 -DMODULE -DMODVERSIONS
-include /usrc/src/linux/include/linux/modversions.h -DEXPORT_SYMTAB
-c tulip.c -o tulip.o
Comment 5 Bill Nottingham 1999-10-14 15:44:59 EDT
If you'd like, you could grab:
http://people.redhat.com/notting/tulip/tulip-dd.img

Put that on a floppy, and then boot bootnet.img with 'linux dd',
and use this when you're prompted for the driver disk.

(Warning: I haven't tested it yet; it may not work right...)

Note You need to log in before you can comment on or make changes to this bug.