Bug 595051 - [anaconda] aborts upon setting up boot partition
Summary: [anaconda] aborts upon setting up boot partition
Keywords:
Status: CLOSED DUPLICATE of bug 563526
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 05:46 UTC by Joachim Frieben
Modified: 2010-06-16 18:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-16 18:42:52 UTC


Attachments (Terms of Use)
anaconda log file saved after the exception occurred (257.63 KB, text/plain)
2010-05-23 05:46 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2010-05-23 05:46:38 UTC
Created attachment 415920 [details]
anaconda log file saved after the exception occurred

Description of problem:
After initiating a network install from media RHEL6.0-20100414.0-AP-x86_64-boot.iso including updates.img as of 2010-05-23 downloaded by the installer, anaconda aborts when the boot partition is set up on a disk on which a fully working F12 is currently installed. The disk layout includes the boot partition /dev/sda2 to which mount point /boot is assigned and an additional LVM partition for the remaining volumes. The file system type is ext4 in all cases. The anaconda log file issued after the unhandled exception is attached to this report.

Version-Release number of selected component (if applicable):
anaconda-13.21.20.5-1.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start install of RHEL6 beta from boot.iso plus downloaded updates.img.
2. Set up disk layout.
3. Choose to reformat existing partition /dev/sda2 with mount point /boot
   and file system type ext4 as before (F12).
  
Actual results:
Installer aborts.

Expected results:
Installer adopts chosen disk layout and proceeds.

Additional info:
- Disk layout is supposed to be recycled from a working F12 system
  without changing any existing partition or volume apart from simply
  reformatting them using the same file system types as before.
- Note that /dev/sda2 was not assigned any partition label when setting
  up partitions from scratch during the preceding install of F12.

Comment 2 Chris Lumens 2010-05-24 14:29:05 UTC
Can you please try again with a later build of anaconda?  13.21.20.5 is rather old at this point and I'm pretty sure this bug should be fixed.

Comment 3 Joachim Frieben 2010-05-24 22:39:59 UTC
Are the any public repositories where I can find updated boot media for the EL6 development tree?

Comment 4 RHEL Product and Program Management 2010-05-27 14:16:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 David Cantrell 2010-06-16 18:42:52 UTC

*** This bug has been marked as a duplicate of bug 563526 ***


Note You need to log in before you can comment on or make changes to this bug.