Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 595067 - modules failed to load in kdump kernel
modules failed to load in kdump kernel
Status: CLOSED DUPLICATE of bug 523995
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 05:14 EDT by Qian Cai
Modified: 2010-05-24 11:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 11:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdump initrd (8.28 MB, application/octet-stream)
2010-05-23 05:38 EDT, Qian Cai
no flags Details

  None (edit)
Description Qian Cai 2010-05-23 05:14:20 EDT
Description of problem:
Kdump kernel failed to load several modules on my X200 and KVM guests. I concern about this a general problem that might affect other modules as well (not only the sound drivers here) which can prevent the loss of vmcore.

Loading snd-ac97-codec.ko module
snd_ac97_codec: Unknown symbol snd_interval_refine
snd_ac97_codec: Unknown symbol snd_pcm_hw_rule_add
insmod: can't insert '/lib/snd-ac97-codec.ko': unknown symbol in module, or unknown parameter
Loading snd-seq.ko module
Loading snd-pcm.ko module
Loading snd-intel8x0.ko module
snd_intel8x0: Unknown symbol snd_ac97_pcm_close
snd_intel8x0: Unknown symbol snd_ac97_resume
snd_intel8x0: Unknown symbol snd_ac97_pcm_open
snd_intel8x0: Unknown symbol snd_ac97_set_rate
snd_intel8x0: Unknown symbol snd_ac97_update_bits
snd_intel8x0: Unknown symbol snd_ac97_mixer
snd_intel8x0: Unknown symbol snd_ac97_bus
snd_intel8x0: Unknown symbol snd_ac97_pcm_double_rate_rules
snd_intel8x0: Unknown symbol snd_ac97_update_power
snd_intel8x0: Unknown symbol snd_ac97_suspend
snd_intel8x0: Unknown symbol snd_ac97_get_short_name
snd_intel8x0: Unknown symbol snd_ac97_pcm_assign
snd_intel8x0: Unknown symbol snd_ac97_tune_hardware
insmod: can't insert '/lib/snd-intel8x0.ko': unknown symbol in module, or unknown parameter

Version-Release number of selected component (if applicable):
RHEL6.0-20100522.n.0
kexec-tools-2.0.0-70.el6

How reproducible:
always

Steps to Reproduce:
1. minimal install a RHEL6 on X200 or KVM guest.
2. setup kdump and crash the system
3. watch the kdump kernel boot
  
Actual results:
several failed module load messages.

Expected results:
All modules loaded.
Comment 1 Qian Cai 2010-05-23 05:38:25 EDT
Created attachment 415930 [details]
kdump initrd
Comment 2 Neil Horman 2010-05-24 11:24:19 EDT
This is another dup of the modprobe issue that we've been waiting on jcm for.

*** This bug has been marked as a duplicate of bug 523995 ***

Note You need to log in before you can comment on or make changes to this bug.