Bug 595090 - SELinux está negando a /usr/bin/boinc_client el acceso "open" on nvidiactl
Summary: SELinux está negando a /usr/bin/boinc_client el acceso "open" on nvi...
Keywords:
Status: CLOSED DUPLICATE of bug 595092
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:5d3836f0a75...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 10:21 UTC by Felipe Hommen
Modified: 2010-05-24 12:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 12:19:24 UTC
Type: ---


Attachments (Terms of Use)

Description Felipe Hommen 2010-05-23 10:21:36 UTC
Resúmen:

SELinux está negando a /usr/bin/boinc_client el acceso "open" on nvidiactl

Descripción Detallada:

[boinc_client es un tipo permisivo (boinc_t). Este acceso no fue denegado.]

SELinux negó el acceso requerido por boinc_client. No se esperaba que este
acceso fuera requerido por boinc_client, y puede ser indicio de un intento de
ataque. También es posible que la versión específica o la configuración de
la aplicación esté provocando esta necesidad de acceso adicional

Permitiendo Acceso:

Puede generar un módulo de política local para permitir este acceso. Vea FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Por favor, informe
este error.

Información Adicional:

Contexto Fuente               system_u:system_r:boinc_t:s0
Contexto Destino              system_u:object_r:xserver_misc_device_t:s0
Objetos Destino               nvidiactl [ chr_file ]
Fuente                        boinc_client
Dirección de Fuente          /usr/bin/boinc_client
Puerto                        <Desconocido>
Nombre de Equipo              (eliminado)
Paquetes RPM Fuentes          boinc-client-6.10.45-1.r21128svn.fc13
Paquetes RPM Destinos         
RPM de Políticas             selinux-policy-3.7.19-15.fc13
SELinux Activado              True
Tipo de Política             targeted
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (eliminado)
Plataforma                    Linux felinux 2.6.33.4-95.fc13.i686 #1 SMP Thu May
                              13 05:55:24 UTC 2010 i686 i686
Cantidad de Alertas           1
Visto por Primera Vez         dom 23 may 2010 12:12:27 CEST
Visto por Última Vez         dom 23 may 2010 12:12:27 CEST
ID Local                      cc9a50f1-c42c-4b1d-ae08-3d160afdc30f
Números de Línea            

Mensajes de Auditoría Crudos 

node=felinux type=AVC msg=audit(1274609547.178:61): avc:  denied  { open } for  pid=3634 comm="boinc_client" name="nvidiactl" dev=devtmpfs ino=13709 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:xserver_misc_device_t:s0 tclass=chr_file

node=felinux type=SYSCALL msg=audit(1274609547.178:61): arch=40000003 syscall=5 success=yes exit=16 a0=bf9632a4 a1=8002 a2=0 a3=926b178 items=0 ppid=1 pid=3634 auid=0 uid=490 gid=476 euid=490 suid=490 fsuid=490 egid=476 sgid=476 fsgid=476 tty=(none) ses=2 comm="boinc_client" exe="/usr/bin/boinc_client" subj=system_u:system_r:boinc_t:s0 key=(null)



Hash String generated from  catchall,boinc_client,boinc_t,xserver_misc_device_t,chr_file,open
audit2allow suggests:

#============= boinc_t ==============
allow boinc_t xserver_misc_device_t:chr_file open;

Comment 1 Miroslav Grepl 2010-05-24 12:19:24 UTC

*** This bug has been marked as a duplicate of bug 595092 ***


Note You need to log in before you can comment on or make changes to this bug.