Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 595096 - udev md script bug
Summary: udev md script bug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 10:54 UTC by Gordan Bobic
Modified: 2015-09-28 02:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 11:53:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
initramfs-2.6.32-19.el6.x86_64.img (11.55 MB, application/octet-stream)
2010-06-23 09:50 UTC, Gordan Bobic
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0523 0 normal SHIPPED_LIVE dracut bug fix and enhancement update 2011-05-18 17:44:57 UTC

Description Gordan Bobic 2010-05-23 10:54:15 UTC
Description of problem:
At kernel boot, the following error gets reported:
udevd[99]: GOTO 'end_container' has no matching label in: '/etc/udev/rules.d/65-md-incremental-imsm.rules'

Version-Release number of selected component (if applicable):
udev-151-7.fc13.x86_64
dracut-004-14.el6.noarch
dracut-kernel-004-14.el6.noarch
kernel-2.6.32-19.el6.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install onto RAID5 root
2. Reboot

Comment 2 RHEL Program Management 2010-05-25 18:06:38 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Harald Hoyer 2010-05-27 12:59:38 UTC
please boot with "rdshell rdbreak" on the kernel command line and in the shell run:

# grep end_container /etc/udev/rules.d/65-md-incremental-imsm.rules

and attach a photo of the output or just write it here.

Comment 4 Gordan Bobic 2010-05-31 14:03:35 UTC
Output is:

GOTO="end_container"
LABEL="end_container"

The same missing label is reported for "do_container", too.

Comment 5 Phil Knirsch 2010-06-09 10:48:17 UTC
How come you have a udev-151-7.fc13 installed? The current udev version in RHEL6 is udev-147-2.X.

I've also tried this with a fresh KVM install here on a RAID5 root and didn't get the error messages.

If you could let us know how to reproduce this that would be excellent.

Thanks & regards, Phil

Comment 6 Gordan Bobic 2010-06-09 11:03:51 UTC
Hmm, I think the updated udev package came from my trying to fix a different udev related issue. The initrd was generated at install time before that, so I don't think it would have affected it.

I'll see if I can get the whole 65-md-incremental-imsm.rules file from the initrd and attach it this weekend.

My general experience of trying RHEL6b in KVM (on CentOS/RHEL 5.x) generally yields considerably different results WRT stability than bare metal (I have only been able to consistently complete a successful setup with the minimal install under KVM), so I'm not sure that your KVM test makes for a validly equivalent use case.

Comment 7 Harald Hoyer 2010-06-09 12:35:05 UTC
(In reply to comment #6)
> Hmm, I think the updated udev package came from my trying to fix a different
> udev related issue. The initrd was generated at install time before that, so I
> don't think it would have affected it.
> 
> I'll see if I can get the whole 65-md-incremental-imsm.rules file from the
> initrd and attach it this weekend.

no need for that... but I would like to know your kernel command line.

Comment 8 Gordan Bobic 2010-06-23 09:43:50 UTC
Here is my kernel line from grub.conf:

kernel /vmlinuz-2.6.32-19.el6.x86_64 ro root=UUID=5ae396eb-d1d6-48fb-8f02-d7901b75c5c3 rd_MD_UUID=b9594022:1c3d0560:9557eee7:7ff48e1f rd_NO_LUKS rd_NO_LVM rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk selinux=0

Comment 9 Gordan Bobic 2010-06-23 09:50:12 UTC
Created attachment 426213 [details]
initramfs-2.6.32-19.el6.x86_64.img

initramfs that exhibits the described behaviour

Comment 12 Alexander Todorov 2010-12-01 14:10:18 UTC
Hi all,
what is the reproducer here? It looks like the reported udev version is not from RHEL6 so I'm in favour of close/notabug.

Comment 14 Gordan Bobic 2010-12-01 15:10:41 UTC
The reason the FC13 version of udev was reported was because I'd tried the Fedora udev to see if it fixed the problem, as I mentioned above. It didn't. The machine is currently running the Beta 2 udev:

udev-147-2.20.el6.x86_64

and the problem still exists.

Comment 17 Martin Banas 2011-04-28 10:25:15 UTC
Can't reproduce on RHEL6.0 Beta 2 from comment 14 on x86_64.

On ppc64 i got following message, but it's not the one from description:
udevd[75]: GOTO 'end_raidstart' has no matching label in: '/etc/udev/rules.d/65-md-incremental-imsm.rules'
udevd[75]: GOTO 'end_raidstart' has no matching label in: '/etc/udev/rules.d/65-md-incremental-imsm.rules'

Gordan, could you please describe steps to reproduce on RHEL6.0 Beta2?

Comment 18 Gordan Bobic 2011-04-28 10:32:26 UTC
The error looks similar enough that they are likely to be related. Considering I have attached the offending initramfs, I'm not sure how much more I can do to provide a reproducible case. I didn't do anything special, I just installed a minimum install straight onto onto a MD RAID5 array.

Comment 21 errata-xmlrpc 2011-05-19 11:53:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0523.html


Note You need to log in before you can comment on or make changes to this bug.