Bug 595151 - Deluge broken in F13
Deluge broken in F13
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 12:28 EDT by bobpoljakov
Modified: 2010-05-27 14:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 14:27:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deluge startup error (931 bytes, application/octet-stream)
2010-05-23 12:28 EDT, bobpoljakov
no flags Details

  None (edit)
Description bobpoljakov 2010-05-23 12:28:49 EDT
Created attachment 415976 [details]
deluge startup error

Description of problem:
After upgrade to F13, deluge can't be used anymore.
After startup, it shows an error, and dont start in classic mode: 
ImportError: libboost_python-mt.so.5: cannot open shared object file: No such file or directory

After switching to non classic mode, there's a connection to 127.0.0.1:<someport> , but Start daemon button does nothing

I've deleted the old config, but it doesn't help.

Version-Release number of selected component (if applicable):
deluge-1.2.0-1.fc13.noarch
deluge-1.2.3-1.fc13.noarch (from koji)


How reproducible:
Start deluge with old config or without any config. Try to use classic mode, or try to start daemon


Steps to Reproduce:
1.Start deluge
2.
3.
  
Actual results:
Python error in classic mode, can't start daemon in non classic mode


Expected results:
working classic mode and working daemon

Additional info:
Comment 1 bobpoljakov 2010-05-27 14:27:19 EDT
I've found the source of the problem. After updating from f12 to f13, rb_libtorrent and rb_libtorrent-python was not upgraded properly. After removing the mentioned packages, and reinstall them, deluge works fine.

Note You need to log in before you can comment on or make changes to this bug.