Bug 595154 - Docky theme - zoom option disabled
Summary: Docky theme - zoom option disabled
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-do
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 17:01 UTC by markm
Modified: 2010-05-24 21:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 17:24:42 UTC
Type: ---


Attachments (Terms of Use)
Screenshot of Gnome-do preferences when Docky theme is selected. (62.20 KB, image/png)
2010-05-23 17:01 UTC, markm
no flags Details

Description markm 2010-05-23 17:01:41 UTC
Created attachment 415979 [details]
Screenshot of Gnome-do preferences when Docky theme is selected.

Description of problem:

When Docky theme is selected, zoom option is disabeld.

Version-Release number of selected component (if applicable):

$ rpm -qa | grep gnome-do
gnome-do-plugins-eog-0.8.2-1.fc12.i686
gnome-do-plugins-firefox-0.8.2-1.fc12.i686
gnome-do-plugins-0.8.2-1.fc12.i686
gnome-do-plugins-evolution-0.8.2-1.fc12.i686
gnome-do-plugins-pidgin-0.8.2-1.fc12.i686
gnome-do-0.8.3.1-1.fc13.i686
gnome-do-plugins-rhythmbox-0.8.2-1.fc12.i686

How reproducible:

always

Steps to Reproduce:
1. start Gnome-do
2. select theme "Docky"
3. try to change "Zoom"
  
Actual results:

Zoom option is disabled and does not work (default value is 110%).

Expected results:

Zoom option to work.

Comment 1 Juan Manuel Rodriguez 2010-05-24 17:24:42 UTC
Its not exactly a bug, but its definitely not a feature. 

This was removed due to a *potential* patent infringement (It's not infringement until the courts say so!) with US Patent 7434177. 

In the end, it was patched out to keep Gnome-Do in Fedora, since the authors are splitting "Docky" into its own package, and removing it entirely from Gnome-Do, though its been a while since their last Gnome-Do / Docky release...

Comment 2 markm 2010-05-24 19:14:30 UTC
This is an issue in US, why all other countries are affected?

Comment 3 Juan Manuel Rodriguez 2010-05-24 21:10:23 UTC
Fedora is hosted in USA, which means it has to abide with American laws, however crazy and ridiculous they might be. 

The alternative would be to distribute this package on an external repository that did not abide to crazy American laws, however users of gnome-do that do not use Docky would not be able to install gnome-do on a "standard Fedora installation". 

For more info, please read this page: 
http://fedoraproject.org/wiki/Software_Patents


Note You need to log in before you can comment on or make changes to this bug.