Bug 595167 - SELinux is preventing python (hplip_t) "read" var_lib_t.
SELinux is preventing python (hplip_t) "read" var_lib_t.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:005d942e25f...
:
: 595164 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 14:36 EDT by Steven Nelli
Modified: 2011-01-30 04:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 03:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Nelli 2010-05-23 14:36:07 EDT
Summary:

SELinux is preventing python (hplip_t) "read" var_lib_t.

Detailed Description:

SELinux denied access requested by python. It is not expected that this access
is required by python and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:hplip_t:s0
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                hplip.state [ file ]
Source                        python
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6-9.fc11
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.12-39.fc11
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.29.4-167.fc11.i586 #1 SMP Wed
                              May 27 17:14:37 EDT 2009 i686 i686
Alert Count                   3
First Seen                    Thu 05 Nov 2009 11:43:07 PM EST
Last Seen                     Thu 05 Nov 2009 11:46:29 PM EST
Local ID                      e4c20c3b-74e0-491d-9f34-ab904550e566
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1257482789.560:57): avc:  denied  { read } for  pid=2109 comm="python" name="hplip.state" dev=dm-0 ino=164484 scontext=system_u:system_r:hplip_t:s0 tcontext=system_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1257482789.560:57): arch=40000003 syscall=5 success=no exit=-13 a0=8a00e70 a1=8000 a2=1b6 a3=8a2ae18 items=0 ppid=2106 pid=2109 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="python" exe="/usr/bin/python" subj=system_u:system_r:hplip_t:s0 key=(null)



Hash String generated from  catchall,python,hplip_t,var_lib_t,file,read
audit2allow suggests:

#============= hplip_t ==============
allow hplip_t var_lib_t:file read;
Comment 1 Miroslav Grepl 2010-05-24 03:22:01 EDT
*** Bug 595164 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2010-05-24 03:23:55 EDT
This is an old avc from F11 on an F12 box. Please fully update your machine.

# yum update

Note You need to log in before you can comment on or make changes to this bug.