Bug 595168 - Hedgewars currently FTBFS in F13
Hedgewars currently FTBFS in F13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hedgewars (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 14:50 EDT by Bruno Wolff III
Modified: 2010-06-14 13:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: hedgewars-0.9.12-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 13:18:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove the -Nu option (596 bytes, patch)
2010-05-23 16:18 EDT, Bruno Wolff III
no flags Details | Diff
Patch to get the spec file to use the no -Nu patch (1.19 KB, patch)
2010-05-23 16:19 EDT, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description Bruno Wolff III 2010-05-23 14:50:05 EDT
Description of problem:
See scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2204246

Version-Release number of selected component (if applicable):
hedgewars-0.9.12-2.fc13

How reproducible:
Happened using rpmbuild locally on an f13 system and with a koji scratch build.

Additional info:

I was looking at seeing what it would take to have the package install a dedicated server for use at the next community gaming session. If I get time, I'll be looking at this bug myself over the next week.
My current guess is that this is a DSO linking issue that didn't get categorized as such because cmake hides the low level messages by default.
My next step is building using verbose mode to get a better idea of what is actually failing.
Comment 1 Bruno Wolff III 2010-05-23 15:26:35 EDT
One problem seems to be at some time people were using -Nu as a pascal compiler option and it no longer seems to be valid for fpc. I think the option was used to specify an unroll loops optimization.
Comment 2 Bruno Wolff III 2010-05-23 16:18:42 EDT
Created attachment 415997 [details]
Remove the -Nu option

So it looks like what happened is either the -Nu option was dropped from fpc or it got more strict about handling unknown options.
Not using this option gets the build to complete again.
I probably be doing an RFE about the dedicated server, so you might not want to rush this change into a new build unless you need it for something else.
Comment 3 Bruno Wolff III 2010-05-23 16:19:47 EDT
Created attachment 415998 [details]
Patch to get the spec file to use the no -Nu patch
Comment 4 Fedora Update System 2010-05-25 09:03:11 EDT
hedgewars-0.9.12-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/hedgewars-0.9.12-3.fc13
Comment 5 Fedora Update System 2010-05-26 17:49:18 EDT
hedgewars-0.9.12-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hedgewars'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/hedgewars-0.9.12-3.fc13
Comment 6 Fedora Update System 2010-06-14 13:18:07 EDT
hedgewars-0.9.12-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.