Bug 595171 - Switching between X to TTY kills audio
Switching between X to TTY kills audio
Status: CLOSED DUPLICATE of bug 608712
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 15:09 EDT by Clemens Eisserer
Modified: 2010-08-04 06:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 06:48:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Frozen Amarok after TTY switch (12.60 KB, text/plain)
2010-05-23 15:09 EDT, Clemens Eisserer
no flags Details
Frozen Firefox after TTY switch (12.77 KB, text/plain)
2010-05-23 15:09 EDT, Clemens Eisserer
no flags Details

  None (edit)
Description Clemens Eisserer 2010-05-23 15:09:04 EDT
Created attachment 415987 [details]
Frozen Amarok after TTY switch

Description of problem:

When I switch from X to a TTY with e.g. Amarok running, sound immediatly stops playing and my soundcard is basically dead.
Programs hang accessing it.


Version-Release number of selected component (if applicable):
Fedora-13 pre-release updated to the latest packages.

How reproducible:
Always

Steps to Reproduce:
1. Start Amarok and play a file
2. Switch to a TTY, by pressing Ctrl+F2, playback stops
3. Switch back to X

Actual results:
Amarok goes crazy, playing flash videos in firefox hangs firefox. No sound at all. Even restarting amarok doesn't help.

Expected results:
Switching to a TTY shouldn't influence sound at all.

Additional info:
Linux cebox 2.6.33.3-85.fc13.i686 #1 SMP Thu May 6 18:44:12 UTC 2010 i686 i686 i386 GNU/Linux

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
Comment 1 Clemens Eisserer 2010-05-23 15:09:36 EDT
Created attachment 415989 [details]
Frozen Firefox after TTY switch
Comment 2 Lubomir Rintel 2010-05-24 04:06:01 EDT
Clemens, are you logged in on the tty you're switching to? You should only use the sound hardware if you're logged on in an active session.
Comment 3 Clemens Eisserer 2010-05-24 06:09:33 EDT
What difference does it make?

When I switch from X to a fresh TTY my sound system is completly messed up, which clearly shouldn't happen.
Comment 4 Lennart Poettering 2010-05-24 09:21:36 EDT
This is expected behaviour. Access to the audio card by processes of your uid is limited to the consoles where you are the owner. This is done for security reasons so that you cannot eavesdrop into what is played back or recorded in other user's sessions, or can fool the user by playing back your own audio in his session. 

This logic has been introduced years ago with the ConsoleKit migration.

Switching back to a console where you are the owner will make audio continue to play.
Comment 5 Clemens Eisserer 2010-05-24 10:53:32 EDT
> Switching back to a console where you are the owner will make audio continue to
> play. 

No it doesn't, and thats what this bug report is about.
As soon as I switch to another terminal, my sound system is dead until i reboot.
Comment 6 Clemens Eisserer 2010-05-30 07:00:59 EDT
Is there anything I could do in order to track that bug down?
Comment 7 Clemens Eisserer 2010-07-01 08:14:19 EDT
any update in this? I also reproduce this problem on another laptop which has an intel audio chip.
Comment 8 Clemens Eisserer 2010-07-23 16:37:43 EDT
ping
Comment 9 Michal Schmidt 2010-08-04 06:48:12 EDT

*** This bug has been marked as a duplicate of bug 608712 ***

Note You need to log in before you can comment on or make changes to this bug.