Bug 59518 - At beginning of Linux install, crashed and disabled laptop from further boots
At beginning of Linux install, crashed and disabled laptop from further boots
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 22:53 EST by Hal Harrison
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 18:31:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log captured on isys.umount failure (893 bytes, text/plain)
2002-02-08 22:55 EST, Hal Harrison
no flags Details

  None (edit)
Description Hal Harrison 2002-02-08 22:53:24 EST
Description of Problem:
I've entered my choices for a custom install on my IBM Thinkpad 390X, nothing on the harddrive.
Click "next" on point-of-no-return screen. It waits for a few minutes showing 00.0, 00.0 etc. then install CD 1 starts reading. 
I had chosen 1,100 KB worth of packages to install into a /usr of only 1 Gig. Popup says, "You need more." OK.
Next popup says something like, You've got a bug. 
Log says: isys.umount() can only umount by mount point

Version-Release number of selected component (if applicable):
anaconda-7.1

How Reproducible:
I'll try installing Monday with different parameters.

Steps to Reproduce:
boot from CD 1
Choose graphical mode install
Generic 101-key PC closest to my laptop 84-key
Generic, 3-button PS/2 mouse
Custom rather than Laptop installation
Manually partition disk with Disk Druid
  I have 6189 M (6.2 Gig)
  /       256M (message recommended) Linux Native
  /usr    1G Linux Native
  /home   1G Linux Native
  /dos    1G DOS 16-bit >=32M
  swap    256M
Install LiLO
No firewall
UTC-5, Daylight Saving, System clock uses UTC
two accounts, root and hh
X config: Video probe found NeoMagic 256 (laptop notebook), 256KB
  video card RAM
X config: monitor, unprobed, horizontal 31.5-48.5 kHz, vertical 50-70
  kHz
Take default color depth 16, sn resolution 1024x768, login text.

Actual Results:
After I copied error logging to diskette, installation dumped out to text screen
"you may safely boot" or something like that.

Expected Results:
A completed install.

Additional Information:
I'll try attaching the log.
Comment 1 Hal Harrison 2002-02-08 22:55:03 EST
Created attachment 45040 [details]
error log captured on isys.umount failure
Comment 2 Michael Fulbright 2002-02-11 11:53:26 EST
If you do not mount the DOS partition during the install process does it work
better?
Comment 3 Hal Harrison 2002-02-12 15:59:49 EST
My goal is dual boot with Win2000 and am told by work mates that I should install Win first (which I did last year on another machine without this kind of problem). My 
attempt to install again from the Red Hat CD was thwarted as follows.

It appears the isys.unmount() failure corrupted the master boot record of my virgin hard drive so that it would not return a proper "boot failure" error to POST. Before 
starting with Linux an attempt to boot produced a short "No OS" message. Also, at first, the laptop booted from RedHat CD 1. After the corruption, an attempt to boot 
from hard drive produced only a blank screen and the CD would not boot. My fincal solution was to reconfigure the machine's boot sequence, putting CD before 
harddrive. But my second Linux install attempt ended directly after the "Welcome to Red Hat" screen with an error like "...logical partition type 0 detected...which 
condition is not supported by the anaconda installer...use your other operating system to set it correctly" what ever "correctly" means. I don't know if that's a result of 
the isys.umount() failure or of my using Partition Magic 6.0 before I reconfigured the boot sequence. P Magic first showed a C: of 250 something Meg, Active FAT. I 
removed it. Boot still wouldn't pass hard drive. But than P Magic said it was still there. So I activated it and formatted it. Still no boot. Then I reconfigured the boot 
sequence as already stated.

In a few days I will start with Win to see if he will straighten out the partitions and then install Linux second.
Comment 4 Brent Fox 2002-03-08 21:07:28 EST
halh, have you made any progress with this issue?
Comment 5 Hal Harrison 2002-03-13 18:30:55 EST
March 13
Yesterday, after several trials, I completed my intended install of Dos, Win2000, and RH Linux 7.1 on my laptop 390X. By forgoing the Dos partition, as you 
suggeseted,  I had no further occurances of the original isys.umount()-umount problem. My problem with disabled boot arose from my inattention to whether Lilo wrote 
his boot record to MBR or another partition. However, there may also be a problem in the RH 7.1 install. Even after choosing "boot partition" instead of MRB, your 
etc/lilo.conf had "boot=/dev/hda". When I ran Lilo with "boot=/dev/hda8" and some other changes, then Linux booting worked as desired in conjunction with Boot 
Magic, 6.0. I also had to repair your etc/fstab. For / and /home it had picked up the volumn labels I assigned with Partition Magic instead of /dev/hda8 and /dev/hda7.
I don't know Linux that well yet, but I'm sure the better it cooperates with Windows now, the quicker we will be free of Windows in the long run.
Comment 6 Jeremy Katz 2002-04-10 14:38:05 EDT
Although I don't remember any problems with the boot loader things in 7.1, I
have tested that it works properly in current releases.

Note You need to log in before you can comment on or make changes to this bug.