Bug 595185 - [Cisco 6.0 bug] libfc: Fix remote port restart problem
Summary: [Cisco 6.0 bug] libfc: Fix remote port restart problem
Keywords:
Status: CLOSED DUPLICATE of bug 603263
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 6.0
Assignee: Mike Christie
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 22:45 UTC by Venkata Siva Vijayendra Bhamidipati
Modified: 2010-07-15 22:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-15 21:48:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
libfc patch 1 of 3 (9.37 KB, patch)
2010-06-07 18:41 UTC, Venkata Siva Vijayendra Bhamidipati
no flags Details | Diff
libfc patch 2 of 3 (893 bytes, patch)
2010-06-07 18:41 UTC, Venkata Siva Vijayendra Bhamidipati
no flags Details | Diff
libfc patch 3 of 3 (2.27 KB, patch)
2010-06-07 18:42 UTC, Venkata Siva Vijayendra Bhamidipati
no flags Details | Diff

Description Venkata Siva Vijayendra Bhamidipati 2010-05-23 22:45:45 UTC
Description of problem:

Currently, if a target sends multiple back-to-back LOGO's, we try to process all of them irrespective of the status of processing of prior LOGOs, which results in an oops in fc_rport_work() in libfc -

  [<ffffffff810a12e1>] ? trace_hardirqs_off+0x9/0x20
  [<ffffffffa031a86c>] ? fc_rport_work+0x0/0x3d4 [libfc]
  [<ffffffff81056d14>] worker_thread+0x149/0x1e5
  [<ffffffff81059c27>] ? autoremove_wake_function+0x0/0x3d
  [<ffffffff81056bcb>] ? worker_thread+0x0/0x1e5
  [<ffffffff810598da>] kthread+0x6e/0x76
  [<ffffffff81003a14>] kernel_thread_helper+0x4/0x10
  [<ffffffff814a4369>] ? restore_args+0x0/0x30
  [<ffffffff8105986c>] ? kthread+0x0/0x76
  [<ffffffff81003a10>] ? kernel_thread_helper+0x0/0x10


Version-Release number of selected component (if applicable):


How reproducible:
Rapid fc uplink flaps on a ucs 6120 at 2 second intervals causes this issue to be run into after a few hours.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Initiator node panics with above stack trace.

Expected results:
All I/Os run normally and node does not panic.

Additional info:
The patch to this bug is being tested, and an earlier patch has been submitted to the upstream kernel. A latest patch with minor changes will be resubmitted upstream and the patch will be attached to this bug as well.

Comment 2 RHEL Program Management 2010-06-07 16:06:48 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Venkata Siva Vijayendra Bhamidipati 2010-06-07 18:39:33 UTC
The fix to this bug has been submitted upstream in three separate patches to libfc. Attaching the RHEL diffs. The upstream patches have not yet been merged into the openfcoe-next git tree. Will update this bug with links to the openfcoe-next commit links when Robert Love merges the fixes.

Comment 4 Venkata Siva Vijayendra Bhamidipati 2010-06-07 18:41:02 UTC
Created attachment 421913 [details]
libfc patch 1 of 3

First patch. Two more follow.

Comment 5 Venkata Siva Vijayendra Bhamidipati 2010-06-07 18:41:33 UTC
Created attachment 421914 [details]
libfc patch 2 of 3

libfc patch 2. 1 more follows.

Comment 6 Venkata Siva Vijayendra Bhamidipati 2010-06-07 18:42:00 UTC
Created attachment 421915 [details]
libfc patch 3 of 3

libfc patch 3.

Comment 7 Venkata Siva Vijayendra Bhamidipati 2010-06-07 18:59:04 UTC
These patches need to be included in the 5.5-z stream as well.

Comment 8 Venkata Siva Vijayendra Bhamidipati 2010-06-11 02:19:28 UTC
The patches have been committed to the open-fcoe-next git tree at -

http://www.open-fcoe.org/wordpress/frame.php?url=http://www.open-fcoe.org/openfc/gitweb/

The commit numbers of these patches are -

36f7ed3655d8f88a10c3142a3763766e3de3b460 libfc: fix indefinite rport restart
b51c2fa951b3ccd117d523dc15ec28ff1402f2e2 libfc: Fix remote port restart problem

The patches merge changes among the 3 diffs attached. Hence, please refer to these upstream diffs.

Comment 9 RHEL Program Management 2010-07-15 14:38:35 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 10 Andrius Benokraitis 2010-07-15 17:56:24 UTC
This is the first I've seen/heard of this. Cisco states this is a blocker since these patches fix crashes. Just received this info.

Comment 11 Mike Christie 2010-07-15 20:37:54 UTC
36f7ed3655d8f88a10c3142a3763766e3de3b460 libfc: fix indefinite rport restart
b51c2fa951b3ccd117d523dc15ec28ff1402f2e2 libfc: Fix remote port restart problem

We have these fixes merged. They are in snap8.

Comment 12 Mike Christie 2010-07-15 20:42:34 UTC
(In reply to comment #11)
> We have these fixes merged. They are in snap8.

Actually, I am not sure if it is snap 8. The bugzilla is here
https://bugzilla.redhat.com/show_bug.cgi?id=603263
The kernel it got merged in is kernel-2.6.32-42.el6

Comment 13 Andrius Benokraitis 2010-07-15 21:48:05 UTC
I'm going to dupe this to bug 603263 and request access to that.

*** This bug has been marked as a duplicate of bug 603263 ***

Comment 14 Andrius Benokraitis 2010-07-15 22:01:35 UTC
Bug 603263 should now be accessible by Cisco. Add yourselves as you see fit.


Note You need to log in before you can comment on or make changes to this bug.