Bug 59519 - installer fails immediately with only SCSI CDROM + IDE harddrives
installer fails immediately with only SCSI CDROM + IDE harddrives
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-02-09 02:27 EST by Ulrich Drepper
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-05 18:24:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2002-02-09 02:27:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020207

Description of problem:
Using netboot.img I mounted a directory containing the 3 binary ISO images. 
anaconda immediately fails with the following messages:

need to look at ['beta1-i386-disc1.iso', 'beta1-i386-disc3.iso',
found {1: 'beta1-i386-disc1.iso', 2: 'beta1-i386-disc2.iso', 3:
'beta1-i386-disc3.iso'} in tree mnt/source
Traceback (most recent call last):
   File "/usr/bin/anaconda", line 608 in ?
   File "/usr/lib/anaconda/iutil.py", line 417, in makeDriveDeviceNodes
       isys.makeDevInode(drive,"/dev/%s" % (drive,))
   File "/usr/lib/anaconda/isys.py", line 237 in makeDevInode
SystemError: (2, 'No such file or directory')

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot with boonet.img boot disk
2.provide info for NFS directory containing the 3 ISOs

Actual Results:  the error message above

Expected Results:  installer continuing

Additional info:
Comment 1 Ulrich Drepper 2002-02-09 02:56:37 EST
Tried to use the boot.img and use CDROM images with the same result.

So I gues it's the hardware combination.  Which is as follows:

- the machine has 3 SCSI CDROMs, *no* IDE CDROM

- it has an Adaptec 29xx controller

- I cannot boot from CDROM due to the lack of IDE CROMs

- I used bootnet.img and boot.img, both fail with the same error

Without a fix for this I cannot do anything.  It's really important that I can
so please make a solution available ASAP.
Comment 2 Ulrich Drepper 2002-02-09 03:00:30 EST
Forgot to mention:

- the two harddrives in the machines are IDE

(yeah, I know, strange machine...)
Comment 3 Ulrich Drepper 2002-02-09 03:32:16 EST
More information: if I select the text installer it works.
Comment 4 Michael Fulbright 2002-02-11 11:28:38 EST
Was there anything else after the last line of the error message you gave above?
Usually there is a dump of all the python interpretter state which would be
helpful, especially if you can safe to floppy.

You could try disconnecting the SCSI cdrom drives if you really need to install
it asap.
Comment 5 Ulrich Drepper 2002-02-22 12:52:36 EST
What I wrote down was everything there was to see.

And I got the beta installed by using the TUI installer.
Comment 6 Jeremy Katz 2002-03-13 00:54:14 EST
Is this any better with beta 2?
Comment 7 Ulrich Drepper 2002-03-16 02:43:46 EST
With beta2 the results are not much better.  Instead of an anaconda message I
get a kernel message.  To the right of the text line in the box (this is TUI)

   Kernel paic: Loop 1

and the machine is frozen.  After lots of SysRq key pressing I'm not sure I
caught the right process but what I saw is this

  eip 0010:[c0116b8c]
  eax: 00000000  ebx e0c7db31  ecx c022668f  edx 00000000
  esi  00000000  edi 00000000  ebp 00000000  ds 0018  es 0018
  cr0  8005003b  cr2 40003090  cr3 1f8a8000  cr4 000002d0
Call Trace: e0c7478a

I copies this by hand so there might be bugs in there.

In case you want to know, the server is a RH7.2 box

Oh, and I think I haven't mentioned this is a dual PII Xeon box.
Comment 8 Ulrich Drepper 2002-03-16 03:03:55 EST
Well, I tried it again.  Now it worked fine.

The difference to the first attempt was that first I mistyped the IP address of
the machine which has is going to be installed.  Trying to mount the NFS
directory failed in this case since there was no route to the host.  After going
back and correcting the IP address the mounting succeeded but the above
mentioned kernel panic stopped everything.

During the second attempt I entered the correct IP address right away, didn't
have failed NFS mount attempts, and everything is fine.
Comment 9 Jeremy Katz 2002-03-18 14:53:27 EST
Arjan, any thoughts on the oops?
Comment 10 Jay Turner 2002-03-21 10:52:40 EST
Ulrich, are you still seeing this issue with the invalid IP address with Beta 3
(Skipjack)?  I'm not able to replicate here in the office, but didn't try with a
'no route to host address' just a 'destination not reachable'
Comment 11 Ulrich Drepper 2002-04-05 18:24:37 EST
I tried to provoke the error on the same machine with, what I think, are the
same steps I did before.  It worked fine, no backtrace.  This is with beta4.

My only issue is that the error message isn't the best.  The kernel has more
information.  Maybe it could be improved.
Comment 12 Jeremy Katz 2002-04-06 12:56:46 EST
There's no way we can change the string now (string freeze is long gone) and
figuring out deeper causes of obscure error messages hit such a small percentage
of the time isn't really worth the likelihood of breaking (since we can't
reproduce it, we can't test that what we do really works)

Note You need to log in before you can comment on or make changes to this bug.