Bug 595205 - Xorg does not start after upgrade to kernel 2.6.32 with Intel q45/q43 chipset and tk-407
Xorg does not start after upgrade to kernel 2.6.32 with Intel q45/q43 chipset...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-23 23:49 EDT by John Z
Modified: 2018-04-11 05:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 09:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log for failure with kernel 2.6.32 (8.85 KB, text/plain)
2010-05-23 23:49 EDT, John Z
no flags Details
xorg log for normal operation with 2.6.31 kernel (77.87 KB, text/plain)
2010-05-23 23:52 EDT, John Z
no flags Details

  None (edit)
Description John Z 2010-05-23 23:49:18 EDT
Created attachment 416019 [details]
Xorg log for failure with kernel 2.6.32

Description of problem:  

After upgrading F12 from a 2.6.31 kernel to 2.6.32 and rebooting the display went blank. Serial console and remote access worked. This problem also occurs with F13 and with 32-bit as well as 64.

The Xorg logs show:
(EE) intel(0): No modes.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found

The problem can be circumvented by specifying nomodeset for the kernel in grub.conf.

The problem only occurs when a Trendmicro TK-407 Keyboard/Video switch is connected between the DVI port and the analog display (a Samsung SyncMaster 955DF).

I am not sure what changed to break the xorg driver going from 2.6.31 to 2.6.31, I've had the KVM for a year now and no problems with it and Fedora.  This was an extremely painful problem and took me many hours over 2 weeks to figure out. There seem to be a few other folks who have had similar problems, although I can't be positive. Hope you can come up with some way of fixing it.  Let me know if you need any more information to diagnose the problem.

Version-Release number of selected component (if applicable):

kernel-2.6.31.5-127.fc12.x86_64 works
kernel-2.6.32.9-70.f12.x86_64 fails
xorg-x11-drv-intel.x86_64       2.9.1-1.fc12 - same version for working and non-working scenarios.


How reproducible:
Everytime


Steps to Reproduce:
1. display connected to TK-407, TK-407 connected to DVI port.
2. boot F12 (or F13) with kernel 2.6.32.
  
Actual results:
Blank display (display powers down).

Expected results:
successful boot as with kernel version 2.6.31.


Additional info:
I've attached working and non-working Xorg logs.  It is easy to reproduce; let me know if anything else is needed.
Comment 1 John Z 2010-05-23 23:52:58 EDT
Created attachment 416021 [details]
xorg log for normal operation with 2.6.31 kernel
Comment 2 Matěj Cepl 2010-05-24 11:32:30 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 John Z 2010-06-26 12:01:16 EDT
I tried to reproduce the problem as you requested, bug unfortunately my display failed completely (i.e. it won't work with any system linux or otherwise).  Hopefully it was the display that caused the problem with linux, and not linux causing my display to fail.  

I've bought a new display and I no longer see this problem.  You can close this bug report out if you want.
Comment 4 Bug Zapper 2010-11-03 10:19:32 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-12-03 09:25:41 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.