Bug 595247 - wrong czech-symbol in kmix
Summary: wrong czech-symbol in kmix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdemultimedia
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 08:02 UTC by Martin Naď
Modified: 2010-06-29 15:37 UTC (History)
7 users (show)

Fixed In Version: kdemultimedia-4.4.4-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-29 15:33:44 UTC
Type: ---


Attachments (Terms of Use)
wrong czech-symbol in kmix (1.00 MB, image/png)
2010-05-24 08:02 UTC, Martin Naď
no flags Details

Description Martin Naď 2010-05-24 08:02:33 UTC
Created attachment 416049 [details]
wrong czech-symbol in kmix

Description of problem:
kmix dont correct show czech symbol (wrong coding/ or use font ,I dont know)

Version-Release number of selected component (if applicable):
kde-l10n-Czech-4.4.3-1.fc13.noarch
kde-l10n-4.4.3-1.fc13.noarch
kdemultimedia-4.4.3-1.fc13.1.x86_64
kdemultimedia-libs-4.4.3-1.fc13.1.x86_64

How reproducible:
everytime

  
Actual results:
kmix dont show corect czech symbol

Expected results:
kmix show corectly czech-symbol or use english-name as default

Additional info:
systemsetting/phonon show corectly czech symbol

Comment 1 Martin Naď 2010-05-24 08:25:44 UTC
when start paste to konsole

kmix(2060): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
kmix(2060): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kmix(2060) sink_input_cb: Ignoring sink-input due to it being designated as an event and thus handled by the Event slider 
kmix(2060) sink_input_cb: Ignoring sink-input due to it being designated as an event and thus handled by the Event slider

Comment 2 Kevin Kofler 2010-05-24 09:07:04 UTC
This is a bug in the KMix PulseAudio integration, it should be using QString::fromUtf8 or QString::fromLocal8Bit (I don't know which is more correct, we need to check what PulseAudio does exactly) to convert the device names from PulseAudio. It's using QString::fromLatin1 or QString::fromAscii now, explicitly or implicitly. (Sadly, fromLatin1 is the default for fromAscii, including the implicit fromAscii. They do that because it's faster than fromUtf8 and does the same thing on stuff which is pure 7-bit ASCII, but IMHO defaulting to fromLocal8Bit or fromUtf8 would make more sense. But we have to live with what Qt does, so we need to call the correct function explicitly.)

Comment 3 Steven M. Parrish 2010-06-05 01:55:29 UTC
This is a issue which needs to be reported upstream.  Please file a report at
http://bugs.kde.org  

Please add upstream report info to this report.  We will monitor the upstream
report for a resolution.

Thanks for the report



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Rex Dieter 2010-06-15 16:20:15 UTC
We've got a test build on the way to try out: (requires kde-4.4.4 in updates-testing):

http://koji.fedoraproject.org/koji/taskinfo?taskID=2251939

Comment 5 Rex Dieter 2010-06-15 16:27:49 UTC
Sorry, this would should build better,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2251961

Comment 6 Rex Dieter 2010-06-16 14:19:21 UTC
Third time is a charm:
https://koji.fedoraproject.org/koji/buildinfo?buildID=178240

Comment 7 Fedora Update System 2010-06-17 14:18:53 UTC
kdemultimedia-4.4.4-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kdemultimedia-4.4.4-2.fc13

Comment 8 Fedora Update System 2010-06-17 14:21:43 UTC
kdemultimedia-4.4.4-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kdemultimedia-4.4.4-2.fc12

Comment 9 Fedora Update System 2010-06-21 12:53:39 UTC
kdemultimedia-4.4.4-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdemultimedia'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kdemultimedia-4.4.4-2.fc12

Comment 10 Fedora Update System 2010-06-21 13:10:29 UTC
kdemultimedia-4.4.4-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdemultimedia'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kdemultimedia-4.4.4-2.fc13

Comment 11 Martin Naď 2010-06-28 17:44:09 UTC
kdemultimedia-4.4.4-2.fc13
kdemultimedia-4.4.90-1.fc13.x86_64

work ok ,show correct czech symbol

Comment 12 Lukáš Tinkl 2010-06-28 17:54:14 UTC
Works ok here as well

Comment 13 Fedora Update System 2010-06-29 15:33:38 UTC
kdemultimedia-4.4.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-06-29 15:37:20 UTC
kdemultimedia-4.4.4-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.