Bug 59528 - pixmap engine X resource leak, visible with xchat/AquaX
pixmap engine X resource leak, visible with xchat/AquaX
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gtk-engines (Show other bugs)
skipjack-beta2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-09 10:44 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 19:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
AquaX gtk theme (80.96 KB, application/octet-stream)
2002-02-09 13:08 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-02-09 10:44:15 EST
Description of Problem:
xchat 
 xchat-1.8.7-1.72.0.i386.

makes X use up all available memory (running connected to 3 irc servers)

Within minutes X uses 256 MB then the machine starts to fail because its out of mem
killin xchat frees the memory in the X process.

the xchat version before the update was fine. reverting now.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Need Real Name 2002-02-09 13:08:05 EST
Created attachment 45077 [details]
AquaX gtk theme
Comment 2 Need Real Name 2002-02-09 13:10:02 EST
reverted to xchat  xchat-1.8.1-2.i386.rpm 
which did not solve the problem. Narrowing it down it seems the bug is not
related to the
xchat update, but to GTK+:
 rpm -qi gtk+      
Name        : gtk+                         Relocations: (not relocateable)
Version     : 1.2.10                            Vendor: Red Hat, Inc.
Release     : 11                            Build Date: Tue 28 Aug 2001 04:00:42
PM CEST
Install date: Thu 13 Dec 2001 10:24:31 PM CET      Build Host:
stripples.devel.redhat.com
Group       : System Environment/Libraries   Source RPM: gtk+-1.2.10-11.src.rpm
Size        : 2381845                          License: LGPL

running xchat and X normally results in
 1564 root      16   0 49488  35M  2832 R     3.3 14.4   5:59 X

switching the gtk Theme to AquaX (attached, not part of the distrib. but easy
enough that it
should work) and running xchat (connected to 3 irc servers and switching back n
forth a bunch, opening new channels etc) results in X suddenly eating up more
and more memory (X is the
lasted updates XFree86-4.1.0-15 
1564 root      18   0 55984  41M  2836 S     4.1 17.0   6:15 X
2 Minutes later:
 1564 root      14   0 59896  45M  2836 R     2.1 18.6   6:22 X
1 More minute:
 1564 root      18   0 71632  56M  2836 R     5.1 23.3   6:25 X
1 more
 1564 root      15   0 83368  67M  2836 R     7.7 28.0   6:32 X

switching the theme back to anything else i have here stops the effect, but does
not release the
memory.  terminating xchat then frees the memory.

X, xchat or gtk bug? As its theme-triggered i suspect gtk.

I have been running the AquaX theme for a while now, no other programm seemed to
trigger
this negative effect, only xchat in both the original and the updated version.

Cheers,

Olaf
Comment 3 Mike A. Harris 2002-02-09 14:06:00 EST
This sounds to me like a gtk bug.  It looks like something is wrong with
the theme which causes gtk to allocate resources from X, probably
pixmaps, and not free them.  That is just an assumption however.

I've got the exact same xchat runing and it hasn't been closed for
2 or three weeks now, and I've got infinite scrollback buffers as
well.  Only using about 40Mb of RAM which seems reasonable given my
configuration.

Reassigning to gtk component for further investigation..
Comment 4 Olaf Schnapauff 2002-04-06 05:55:32 EST
Still present in skipjack beta4!
Comment 5 Olaf Schnapauff 2002-04-06 05:57:53 EST
Changed summary to reflect situation. Please not that its present in xchat/gtk+
versions
of skipjack beta4 not only the ones mentioned above.
Comment 6 Owen Taylor 2002-04-06 06:06:18 EST
Note that we dont' ship the AquaX theme, so we don't support using it.

In fact, you would be advised to not to use any Pixmap GTK+ themes; the
GTK+-1.2 pixmap engine has various problems.

It's possible this may be the same problem as:

  http://bugzilla.gnome.org/show_bug.cgi?id=76054
Comment 7 Owen Taylor 2002-04-06 06:08:05 EST
condensed summary.
Comment 8 Olaf Schnapauff 2002-04-06 11:20:45 EST
I agree this looks exactly like http://bugzilla.gnome.org/show_bug.cgi?id=76054

Hope we will get a gtk+ fix here.
Changed component back to gtk+ , I think i set it to ipsvadm accidentally when
moving this
bug to skipjack
Comment 9 Owen Taylor 2002-04-10 19:11:18 EDT
I have no immediate plans to work on this... the pixmap engine 
and imlib are generally code disasters and in the best of cases
pixmap themes using the pixmap engine don't work very well. 
(The GTK+-2.0 pixbuf-engine works much better.) Limited time 
is best spent elsewhere.
Comment 10 Owen Taylor 2002-04-11 15:57:33 EDT
Turned out to be pretty easy to find with code inspection.

* Thu Apr 11 2002 Owen Taylor <otaylor@redhat.com>
- Fix major pixmap leak that occurred with certain theme/app 
  combinations (#59528)

(I think this was the leak ... tried AquaX and xchat before
patching, leaked server memory all over the place. Tried afterwards,
didn't do it any more.)

Note You need to log in before you can comment on or make changes to this bug.