Bug 595288 - Fail to dump the core of domain to a file
Fail to dump the core of domain to a file
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 05:55 EDT by LiZhang Li
Modified: 2010-05-26 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 06:24:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LiZhang Li 2010-05-24 05:55:52 EDT
Description of problem:
When using "virsh dump 4 dump_file"
getting messages:
error: Failed to core dump domain 4 to dump_file
error: operation failed: Migration unexpectedly failed

Version-Release number of selected component (if applicable):
libvirt-client-0.8.1-6.el6.x86_64
libvirt-python-0.8.1-6.el6.x86_64
libvirt-0.8.1-6.el6.x86_64

qemu-kvm-0.12.1.2-2.60.el6.x86_64
qemu-img-0.12.1.2-2.60.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.60.el6.x86_64

# uname -r
2.6.32-25.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.
# virsh list
 Id Name                 State
----------------------------------
  4 rhel6_x86_64_kvm     running

2.
# virsh dump 4 dump_file
error: Failed to core dump domain 4 to dump_file
error: operation failed: Migration unexpectedly failed


  
Actual results:
error: Failed to core dump domain 4 to dump_file
error: operation failed: Migration unexpectedly failed


Expected results:
dump the core of a domain to the dump_file


Additional info:

# virsh dumpxml 4
<domain type='kvm' id='4'>
  <name>rhel6_x86_64_kvm</name>
  <uuid>d6fbc15a-b0b2-44f1-cb00-0a1d404fd9ae</uuid>
  <description> Template domain xml file for testing </description>
  <memory>2097152</memory>
  <currentMemory>2097152</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='rhel6.0.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <source file='/tmp/RHEL-Server-6-64-virtio.qcow2'/>
      <target dev='hda' bus='ide'/>
      <alias name='ide0-0-0'/>
      <address type='drive' controller='0' bus='0' unit='0'/>
    </disk>
    <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <interface type='network'>
      <mac address='54:52:00:1b:d2:63'/>
      <source network='default'/>
      <target dev='vnet0'/>
      <model type='rtl8139'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/1'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='pty' tty='/dev/pts/1'>
      <source path='/dev/pts/1'/>
      <target port='0'/>
      <alias name='serial0'/>
    </console>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5900' autoport='yes' keymap='en-us'/>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
  </devices>
  <seclabel type='dynamic' model='selinux'>
    <label>system_u:system_r:svirt_t:s0:c82,c660</label>
    <imagelabel>system_u:object_r:svirt_image_t:s0:c82,c660</imagelabel>
  </seclabel>
</domain>
Comment 2 LiZhang Li 2010-05-26 06:22:35 EDT
It is not a bug,the dump file can be dump tp /var/lib/libvirt/images/ dir.
It is the SELinux.

Note You need to log in before you can comment on or make changes to this bug.