Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595305 - gnomevfs-info is recognizing nfs mounts as local filesystems
gnomevfs-info is recognizing nfs mounts as local filesystems
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 06:37 EDT by Lubos Kocman
Modified: 2015-03-03 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 11:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2010-05-24 06:37:14 EDT
Description of problem:

gnomevfs-info is recognizing filesystems mounted over NFS as local filesystems:

example:

lkocman@ThinkPad T400$ gnomevfs-info /mnt/archive/tmp | grep Local
Local             : YES

lkocman@ThinkPad T400$ df -h /mnt/archive/tmp/
Filesystem            Size  Used Avail Use% Mounted on
filer-eng.brq.redhat.com:/vol/engineering/share
                      100G   31G   70G  31% /misc/filer-eng/vol/engineering/share


Version-Release number of selected component (if applicable):

gnome-vfs2-2.24.2-6.el6.x86_64

How reproducible:


Steps to Reproduce:
1. gnomevfs-info /mnt/filesystem_mounte_over_nfs

  
Actual results:

Local: YES

Expected results:

Local: NO
Comment 2 Tomáš Bžatek 2010-05-24 11:03:18 EDT
Looking into the gnome-vfs2 sources it's clear that the flag is always set for the file method and never set otherwise (see GNOME_VFS_FILE_INFO_SET_LOCAL() macro usage). See http://library.gnome.org/devel/gnome-vfs-2.0/stable/gnome-vfs-20-gnome-vfs-file-info.html for more information.

The flag 'local' here isn't meant to distinguish between physically available media and the virtual ones, it just indicates ability to access the files directly via POSIX calls. It's a different way of thinking.

This is by design behaviour and correcting this would probably break applications, nominating for devel_ack-. Should this make troubles in real life applications, please let us know here.
Comment 3 RHEL Product and Program Management 2010-05-24 11:08:32 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.