Bug 595311 - high CPU on Dell laptop using nouveau
high CPU on Dell laptop using nouveau
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
13
All Linux
medium Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 06:51 EDT by Peter Robinson
Modified: 2010-10-05 09:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 09:24:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from boot of 2.6.33.4-95.fc13.x86_64 (78.55 KB, text/plain)
2010-05-24 06:55 EDT, Peter Robinson
no flags Details
xorg.log output (184.46 KB, text/plain)
2010-05-24 06:58 EDT, Peter Robinson
no flags Details
Smolt Profile (7.19 KB, text/plain)
2010-05-24 07:23 EDT, Peter Robinson
no flags Details
drm.debug=15 2.6.33.4-95.fc13.x86_64 /var/log/dmesg (122.87 KB, text/plain)
2010-05-24 09:14 EDT, Peter Robinson
no flags Details
drm.debug=15 2.6.33.4-95.fc13.x86_64 from dmesg command (122.81 KB, text/plain)
2010-05-24 09:16 EDT, Peter Robinson
no flags Details
NV xorg.0.log (78.91 KB, text/plain)
2010-05-25 07:56 EDT, Peter Robinson
no flags Details
GDM login screen with NV driver (639.60 KB, image/jpeg)
2010-05-25 07:57 EDT, Peter Robinson
no flags Details

  None (edit)
Description Peter Robinson 2010-05-24 06:51:36 EDT
I've seeing high CPU on my Dell Latitude D630c. I'm seeing the issue when I'm using the on board panel as well as dual screen with an external DVI monitor.

It worked perfectly in F-12 so its a regression. I initially did a 'yum upgrade' and was seeing the problem so did a complete clean re-install and the problem persists. Its somewhat intermittent but occurs on regular intervals either with or without the second screen attached. 

There's no xorg.conf as it uses standard Fedora autodetect.

[perobinson@neo ~]$ xrandr
Screen 0: minimum 320 x 200, current 2880 x 900, maximum 8192 x 8192
LVDS-1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
   1440x900       60.0*+
   1152x864       60.0  
   1024x768       59.9  
   800x600        59.9  
   640x480        59.4  
   720x400        59.6  
   640x400        60.0  
   640x350        59.8  
VGA-1 disconnected (normal left inverted right x axis y axis)
DVI-D-1 connected 1440x900+1440+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900       59.9*+   75.0  
   1280x1024      75.0     60.0  
   1280x800       59.8  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
[perobinson@neo ~]$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G86M [Quadro NVS 135M] (rev a1)
Comment 1 Peter Robinson 2010-05-24 06:55:45 EDT
Created attachment 416084 [details]
dmesg output from boot of 2.6.33.4-95.fc13.x86_64

This is the dmesg output from boot with dual screen./
Comment 2 Peter Robinson 2010-05-24 06:58:55 EDT
Created attachment 416086 [details]
xorg.log output

Output from the current xorg.log
Comment 3 Peter Robinson 2010-05-24 07:19:43 EDT
Current relevant packages are:

kernel-2.6.33.3-85.fc13.x86_64
kernel-2.6.33.4-95.fc13.x86_64
libdrm-2.4.20-1.fc13.x86_64
mesa-libGL-7.8.1-6.fc13.x86_64
mesa-dri-drivers-7.8.1-6.fc13.i686
mesa-libGLU-7.8.1-6.fc13.i686
mesa-dri-drivers-experimental-7.8.1-6.fc13.x86_64
mesa-libGL-7.8.1-6.fc13.i686
mesa-libGLU-7.8.1-6.fc13.x86_64
mesa-dri-drivers-7.8.1-6.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
xorg-x11-drv-nouveau-0.0.16-6.20100423git13c1043.fc13.x86_64
Comment 4 Peter Robinson 2010-05-24 07:23:28 EDT
Created attachment 416090 [details]
Smolt Profile
Comment 5 Peter Robinson 2010-05-24 09:14:41 EDT
Created attachment 416117 [details]
drm.debug=15 2.6.33.4-95.fc13.x86_64 /var/log/dmesg

First stage of the boot from /var/log/dmesg with drm.debug=15
Comment 6 Peter Robinson 2010-05-24 09:16:42 EDT
Created attachment 416118 [details]
drm.debug=15 2.6.33.4-95.fc13.x86_64 from dmesg command

output from dmesg command for later section of the drm.debug=15 boot.
Comment 7 Ben Skeggs 2010-05-24 18:33:32 EDT
1. What exactly makes you suspect this has anything to do with your GPU?
2. Can we see some numbers?
Comment 8 Peter Robinson 2010-05-24 19:01:53 EDT
(In reply to comment #7)
> 1. What exactly makes you suspect this has anything to do with your GPU?

Because its happening across multiple applications (firefox, eipiphany, evolution, pidgin) randomly and when watching top is seems to rotate between X and the app. It doesn't happen on my intel GPU based devices, but then they are i686 vs x86_64. I though it was only when I was connected to dual screens but it seems to happen all the time now, and the laptop itself seems to be running massively more hot now (not sure that's the gpu but it seems to be linked).

> 2. Can we see some numbers?    

What sort of numbers? Most of the time one of the two cores is at or close to 100% but it rotates about, I run the gnome cpu applet with user/system/iowait/nice etc. Its similar to, but not necessarily the same as other reports against nouveau and in all the years that I've run fedora etc those sort of issues across multiple apps tend to be X (no offence I appreciate your work). Before I upgraded to F-13 I was running the same versions of evolution and firefox (taken F-13 srpms and recompiled them on F-12) and I didn't have any issues. I've been running the same apps on F-13 on my netbook without the same issues. I did a 'yum upgrade' on this laptop and I started seeing high CPU issues. I then did a completely clean reinstall without restoring gonme settings (complete clean evolution restore, resynced my bookmarks in firefox via weave) and it still exists. I would run the apps through gdb but I'm not sure how to do that effectively on apps that I need to be able to use for work.
Comment 9 Ben Skeggs 2010-05-24 19:17:13 EDT
By numbers I meant CPU usage numbers for where you say it's high, thanks for that!

Okay, the fact you see the apps also with large CPU usage numbers (and not just X) does make me think something else is probably responsible.  But, who knows at this point.

Is there any chance you can try nv and/or vesa and see how you fare?
Comment 10 Peter Robinson 2010-05-24 19:40:37 EDT
> Is there any chance you can try nv and/or vesa and see how you fare?    

Sure, how? I tried nomodeset on the kernel command line and it just crawled (could see the lines going up the screen as it re-drew). And this laptop has been absolutely spectacular on non 3D for ages (I think I had an issue with the dual screen on nouveau just prior to F-11 but it was fixed) and I really don't want to have to reinstall to F-12 (its my work laptop)
Comment 11 Ben Skeggs 2010-05-24 19:55:51 EDT
You need to append "nomodeset" and create an xorg.conf with:

Section "ServerLayout"
  Identifier "nv-layout"
  Screen "nv-screen"
EndSection

Section "Screen"
  Identifier "nv-screen"
  Device "nv-device"
EndSection

Section "Device"
  Identifier "nv-device"
  Driver "nv"
EndSection


For vesa simply swap Driver "nv" for Driver "vesa".
Comment 12 Peter Robinson 2010-05-25 07:56:06 EDT
Created attachment 416368 [details]
NV xorg.0.log

The NV driver didn't work well. I got weird colours on the GDM screen (will attach picture). The xorg.conf file was as follows:

# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen         "nv-screen" 0 0
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1440x900"
	HorizSync    31.5 - 56.0
	VertRefresh  56.0 - 65.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "nv-device"
	Driver      "nv"
EndSection

Section "Screen"
	Identifier "nv-screen"
	Device     "nv-device"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Comment 13 Peter Robinson 2010-05-25 07:57:04 EDT
Created attachment 416369 [details]
GDM login screen with NV driver

This is the GDM login screen with the standard F-13 background.
Comment 14 Peter Robinson 2010-05-25 08:02:00 EDT
NV driver doesn't really work at all. See above. I'm running at the moment on the vesa driver which doesn't detect my 2nd screen but a minor pain. The CPU seems to be OK at the moment but I've been running it for about 10 mins and it sometime takes a while. I'll run like this for the rest of the  day and see how I get on.
Comment 15 Peter Robinson 2010-05-25 09:52:19 EDT
I've been running on the vesa driver now for 2-3 hours with no heavy cpu spokes to 100% by any of the usual suspects such as evo/firefox/pidgin/epiphany.
Comment 16 Peter Robinson 2010-05-25 17:29:41 EDT
It seems that its been running mostly OK for most of the day on the vesa driver. How can I debug this further?
Comment 17 Peter Robinson 2010-06-02 05:32:16 EDT
With more playing on this I don't get the high CPU if I use nouveau with nomodeset on the kernel command line. Unfortunately i also don't get dual screens and the refresh is really slow at times.
Comment 18 Peter Robinson 2010-10-05 09:24:39 EDT
HW has gone so I can't even test this any more,

Note You need to log in before you can comment on or make changes to this bug.