Bug 595367 - features/recursion Error running make (expected 0; got 512): make -f work/features/recursion.mk CFLAGS=-O -w-j 2 FAILED (1/2 passed)
features/recursion Error running make (expected 0; got 512): make -f work/fea...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: make (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Petr Machata
Michal Nowak
: FutureFeature, Regression
Depends On:
Blocks: 600004
  Show dependency treegraph
 
Reported: 2010-05-24 09:32 EDT by Michal Nowak
Modified: 2015-05-04 21:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: make-3.81-19.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:08:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testsuite fix (530 bytes, patch)
2010-05-26 09:58 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Michal Nowak 2010-05-24 09:32:30 EDT
Description of problem:

This test case from make test suite seems to fail at all archs on current RHEL.

...
features/patternrules ................................... ok     (5 passed)
features/quoting ........................................ ok     (1 passed)
features/recursion ...................................... Error running make (expected 0; got 512): make -f work/features/recursion.mk CFLAGS=-O -w-j 2
FAILED (1/2 passed)
features/reinvoke ....................................... ok     (4 passed)
features/se_explicit .................................... ok     (5 passed)
...

However it seems it worked before (looking at results from Brew).

Version-Release number of selected component (if applicable):

make-3.81-18.1.el6.i686
gcc-4.4.4-4.el6.i686
glibc-2.12-1.2.el6.i686
Linux auto-i386-001.ss.eng.bos.redhat.com 2.6.32-28.el6.i686 #1 SMP Thu May 20 14:25:31 EDT 2010 i686 i686 i386 GNU/Linux

How reproducible:

always

Steps to Reproduce:

1. Run the testsuite, or perhaps the testsuite itself shoul do the job.
  
Expected results:

`make` or testsuite itself should be fixed.

Additional info:

Tarball here http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=14205849  but nothing special in it.
Comment 1 RHEL Product and Program Management 2010-05-24 09:50:56 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.
Comment 4 Petr Machata 2010-05-26 09:58:30 EDT
Created attachment 416845 [details]
Testsuite fix

Reported upstream:
  https://savannah.gnu.org/bugs/index.php?29968
Comment 7 releng-rhel@redhat.com 2010-11-10 16:08:51 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.