Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595384 - fix soname versions
fix soname versions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dmraid (Show other bugs)
6.0
All Linux
medium Severity low
: rc
: ---
Assigned To: Heinz Mauelshagen
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 10:01 EDT by Daniel Mach
Modified: 2010-10-13 07:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 07:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2010-05-24 10:01:44 EDT
dmraid uses non-standard soname versioning:
/lib/libdmraid-events-isw.so.1.0.0.rc16
/lib/libdmraid.so.1.0.0.rc16

Could you remove the .rcX suffix?
Comment 1 RHEL Product and Program Management 2010-05-24 10:06:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Alasdair Kergon 2010-05-24 10:39:23 EDT
Let's update this to incorporate similar clean-ups to those we recently applied to lvm2.
Comment 3 Heinz Mauelshagen 2010-05-25 07:02:10 EDT
(In reply to comment #0)
> dmraid uses non-standard soname versioning:
> /lib/libdmraid-events-isw.so.1.0.0.rc16
> /lib/libdmraid.so.1.0.0.rc16
> 
> Could you remove the .rcX suffix?    

Daniel,
the 'standard' naming is provided.

The .rcX is for the dmraid versioning purpose.

Do you feel this really mandatory to get removed?
Comment 4 Daniel Mach 2010-05-25 08:03:16 EDT
Heinz,
dmraid is the only package in RHEL which didn't pass the test.
Every other package (okay, except openssl which has a letter in the version) has only numbers and dots in the .so version.

From release-engineering perspective, I'd like to have it changed.
Anytime you change package version, soname changes as well and we have to make sure all dependant packages are rebuilt.
Comment 5 Heinz Mauelshagen 2010-05-25 09:14:25 EDT
Daniel,

the packages (namely python-pyblock) are being linked against libdmraid.so.1,
not the ".rcX" sufficed one anyway, hence no issue with ".rcX" changes.

Then this is only about the glob hitting "rcX", no?
Comment 6 RHEL Product and Program Management 2010-07-15 10:12:13 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 Heinz Mauelshagen 2010-10-13 07:59:50 EDT
Closing because linking happens vs. numerically suffixed lib.

Note You need to log in before you can comment on or make changes to this bug.