Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595385 - Provide fence-rhev agent that uses the RHEV REST API
Provide fence-rhev agent that uses the RHEV REST API
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.5
All Linux
high Severity medium
: rc
: ---
Assigned To: Marek Grac
Brandon Perkins
: FutureFeature
Depends On: 595383 637830
Blocks: 595458 607640 681652
  Show dependency treegraph
 
Reported: 2010-05-24 10:01 EDT by Perry Myers
Modified: 2011-03-16 19:28 EDT (History)
10 users (show)

See Also:
Fixed In Version: cman-2.0.115-61.el5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 595383
: 681652 (view as bug list)
Environment:
Last Closed: 2011-01-13 17:34:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fence agent for RHEV-M REST API (3.10 KB, text/plain)
2010-09-24 12:14 EDT, Marek Grac
no flags Details
Fencing library (28.45 KB, text/plain)
2010-09-24 12:15 EDT, Marek Grac
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0036 normal SHIPPED_LIVE cman bug-fix and enhancement update 2011-01-12 12:39:38 EST

  None (edit)
Description Perry Myers 2010-05-24 10:01:58 EDT
+++ This bug was initially created as a clone of Bug #595383 +++

Description of problem:
fence_dcloud implementation might be a longer term target since it involves getting dcloud support formally into RHEL.  In addition, dcloud packages won't be in RHEL5.  So we need a fence_rhev agent that uses the RHEV REST API instead of relying on the generic dcloud support.  Eventually in RHEL6 fence_rhev can be replaced by fence_dcloud.  But we need a shorter term solution and a REST based fence agent should be simple to develop and test.

This bug is dependent on full support for the RHEV REST API.  Once a bug has been filed on that the dependency should be set.
Comment 1 Brandon Perkins 2010-07-14 12:11:21 EDT
qa_ack+
Comment 2 Marek Grac 2010-09-24 12:14:14 EDT
Created attachment 449455 [details]
Fence agent for RHEV-M REST API
Comment 3 Marek Grac 2010-09-24 12:15:38 EDT
Created attachment 449456 [details]
Fencing library
Comment 7 Brandon Perkins 2010-11-02 14:33:21 EDT
Just so followers of this bug are aware, QA is aware this bug is ON_QA.  We are stalled due to lack of hardware and infrastructure to perform this testing.  This is being addressed on two fronts:

A) Buying new dedicated hardware for RHEV+RHCS testing (similar to VMware+RHCS and KVM+RHCS testing).  However, this is a slow process with a few hiccups along the way.

B) Taking a slice off of the new cluster in Westford temporarily.  Dean and Chris Feist are working on making nodes available.

If anyone has any leverage to move "A" along faster, that would be much appreciated.
Comment 9 errata-xmlrpc 2011-01-13 17:34:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0036.html

Note You need to log in before you can comment on or make changes to this bug.